#2404 closed help (answered)

Branch conflict

Reported by: nfreychet Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 10.7

Description

Hello,

I run the UM10.7, and trying to add a branch set for UM10.3 for regional nudging dumping. branches/dev/joserodriguez/vn10.3_nudg_horiz_damping@50336 (based on the suite of Jose Rodriguez: u-ai544)
If I simply add the branch, I get the following error:

[FAIL] READ_JULES_NAMELISTS_MOD.mod: same target from [jules/src/initialisation/um/read_jules_namelists_mod.F90, um/src/atmosphere/land_surface/initialisation/read_jules_namelists_mod.F90]
[FAIL]     required by: readlsta.o
[FAIL]     required by: um_shell.o
[FAIL]     required by: um-atmos.exe

So it seems there's a conflict with Jules.
In the original suite, there's also a branch for Jules so I tried to add it too (branches/pkg/Config/vn4.4_GlobalAtmos7p0@2933) but if I do so I get the error:

[FAIL] ITEM_BOUNDA_MOD.mod: bad or missing dependency (type=1.include)
[FAIL]     required by: read_atmos_lbcs.o
[FAIL]     required by: up_bound.o
[FAIL]     required by: lbc_update.o
[FAIL]     required by: u_model_4a.o
[FAIL]     required by: um_shell.o
[FAIL]     required by: um-atmos.exe
[FAIL] ITEM_BOUNDA_MOD.mod: bad or missing dependency (type=1.include)
[FAIL]     required by: inbounda.o
[FAIL]     required by: lbc_update.o
[FAIL]     required by: u_model_4a.o
[FAIL]     required by: um_shell.o
[FAIL]     required by: um-atmos.exe

[FAIL] fcm make -C /work/n02/n02/nfreyche/cylc-run/u-av080/share/fcm_make_um -n 2 -j 6 # return-code=255
Received signal ERR
cylc (scheduler - 2018-02-15T15:18:32Z): CRITICAL Task job script received signal ERR at 2018-02-15T15:18:32Z
cylc (scheduler - 2018-02-15T15:18:32Z): CRITICAL failed at 2018-02-15T15:18:32Z

What I need is the branch for nudging damping. But I'm not quite sure how to resolve the problem of compatibility.

Change History (3)

comment:1 Changed 20 months ago by ros

Hi Nico,

The branches need to be at the corresponding UM10.7 versions - you won't be able to use a UM10.3 branch in a 10.7 suite. Similarly the version of Jules used in 10.7 UM suites is Jules 4.8 not 4.4.

You will need to see if there is an equivalent of these branches at the newer versions. If not, and if using a 10.3 suite is not an option, you will have to upgrade those branches, however through that many versions I suspect upgrading the branches will not be trivial.

Cheers,
Ros.

comment:2 Changed 20 months ago by nfreychet

Hi Ros,

Thanks. I think I will try to adapt the branch to the vn10.7, it seems to be quite simple branch.

I have another problem when starting the suite without any branch. The model is built fine, but during the recon step I have that:

[WARN] file:STASHC: skip missing optional source: namelist:exclude_package(:)
[WARN] file:IOSCNTL: skip missing optional source: namelist:lustre_control
[WARN] file:IOSCNTL: skip missing optional source: namelist:lustre_control_custom_files
[WARN] file:IDEALISE: skip missing optional source: namelist:idealise
[WARN] file:RECONA: skip missing optional source: namelist:trans(:)
[11] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[19] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[16] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[9] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[18] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[10] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[3] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[2] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[5] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[8] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[4] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[17] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[6] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[7] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[15] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[22] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[13] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[12] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[20] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[23] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[14] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[21] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[1] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)
[0] exceptions: feenableexcept() mask [0x00000000] enabled. (mask [0x00000000] requested)

????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!!       ERROR        ???!!!???!!!???!!!???!!!???!!!
?  Error code: 4324
?  Error from routine: CHECK_IOSTAT
?  Error message:
?        Error reading namelist NLCFILES
?        IoMsg: The variable name 'RPSEED' is unrecognized in namelist input.
?        Please check input list against code.
?  Error from processor: 0
?  Error number: 0
????????????????????????????????????????????????????????????????????????????????

[0] exceptions: An non-exception application exit occured.
[0] exceptions: whilst in a serial region
[0] exceptions: Task had pid=34377 on host nid03283
[0] exceptions: Program is "/work/n02/n02/nfreyche/cylc-run/u-av080/share/fcm_make_um/build-recon/bin/um-recon.exe"
Warning in umPrintMgr: umPrintExceptionHandler : Handler Invoked
Rank 0 [Thu Feb 15 17:29:48 2018] [c1-2c0s4n3] application called MPI_Abort(MPI_COMM_WORLD, 9) - process 0
_pmiu_daemon(SIGCHLD): [NID 03283] [c1-2c0s4n3] [Thu Feb 15 17:29:48 2018] PE RANK 0 exit signal Aborted
[NID 03283] 2018-02-15 17:29:48 Apid 30042190: initiated application termination
[FAIL] um-recon # return-code=134
Received signal ERR
cylc (scheduler - 2018-02-15T17:29:49Z): CRITICAL Task job script received signal ERR at 2018-02-15T17:29:49Z
cylc (scheduler - 2018-02-15T17:29:49Z): CRITICAL failed at 2018-02-15T17:29:49Z

I suppose I need to do some more work to set the STASH correctly on ARCHER, but it doesn't seem to be the main problem here. I don't know what RPSEED problem is. Or is it actually due to a bad STASH setting?

(my suite is u-av080)

Cheers,
Nico

Last edited 20 months ago by nfreychet (previous) (diff)

comment:3 Changed 20 months ago by ros

  • Resolution set to answered
  • Status changed from new to closed

Closing ticket as this has now become a duplicate of Ticket #2405.

Note: See TracTickets for help on using tickets.