Opened 8 months ago

Closed 5 months ago

#2412 closed help (fixed)

UM6.6 code browser not available

Reported by: watson Owned by: ros
Priority: normal Component: Website
Keywords: code browser Cc:
Platform: UM Version: 6.6.3

Description

Hello, I wanted to check the code in UM6.6 and tried using the code browser (http://cms.ncas.ac.uk/code_browsers/UM6.6/UMbrowser/index.html), but it comes up with a "Page not found" error). When I tried searching using the search box, it just produces some dialogue relating to perl in the bottom left window. Is it possible to restore the functionality of this?

Change History (12)

comment:1 Changed 8 months ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Peter,

You can ignore the "page not found" error, that's just because the provider of f90tohtml at the time of vn6.6 is no longer or no longer has the same URL. You can still select one of the subroutine links and the code is displayed fine and you can click through as expected.

The search is more problematic, nothing has changed anything since it was put up and I've checked that everything is the same as for the other versions which are working ok. I will add it to the list of things to be sorted out, but unfortunately it is unlikely to be fixed immediately.

Cheers,
Ros.

comment:2 Changed 8 months ago by watson

OK, thanks Ros.

Peter

comment:3 Changed 8 months ago by watson

Is there a way I could download the code to my own computer so that I can search it?

Peter

comment:4 Changed 8 months ago by ros

Hi Peter,

Check out the trunk in the same way as you would for a branch: fcm co fcm:um-tr@hg6.6.3. You'll need to do this on PUMA.

Cheers,
Ros.

comment:5 Changed 7 months ago by willie

  • Status changed from accepted to new

comment:6 Changed 7 months ago by willie

  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 7 months ago by watson

Hi, I just got an email saying this had been marked as "fixed" and "closed". However, when I tried accessing the code browser just now, I still got errors when I tried to search, so it doesn't seem to be fixed to me.

comment:8 Changed 7 months ago by watson

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:9 Changed 7 months ago by watson

I reopened the ticket since the error is still there for me.

comment:10 Changed 6 months ago by ros

  • Component changed from UM Model to Website
  • Resolution set to wontfix
  • Status changed from reopened to closed

Hi Peter,

I've taken another look at this and it is all set up in exactly the same way as all the other versions. Permission identical, content identical. I can't see anything wrong with it. The main part of the code browser works fine, it's just the search which doesn't. I know it's not ideal but it is possible to search the source code in other ways as a workaround. Unfortunately we don't have the resources to spend further time on this.

Regards,
Ros

comment:11 Changed 5 months ago by ros

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Hi Peter,

Whilst generating the code browser for the latest UM version it's dawned on me what was wrong with the UM6.6 one! So the search now works for UM6.6.

Cheers,
Ros.

[CMS Note: Problem caused by an incorrect/missing .htaccess file in the cgi-bin directory]

comment:12 Changed 5 months ago by ros

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.