Opened 7 months ago

Closed 4 months ago

#2426 closed help (answered)

Email non-delivery messages

Reported by: apm Owned by: ros
Priority: normal Component: Rose/Cylc
Keywords: Cc:
Platform: PUMA UM Version:

Description

While I am running Rose/Cylc? jobs on Archer via Puma, I get several e-mail notifications every day about mail non-delivery (see below for an example). I see that it is trying to send mail to apm@…, but I don't have an account at Reading.

Is there somewhere in the system I can change this and stop all these e-mails?

Thanks,

Alex

This is the mail system at host puma.reading.ac.uk.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<apm@…> (expanded from <apm@localhost>): host

smtp.reading.ac.uk[134.225.34.99] said: 550-Verification failed for
<apm@…> 550-Unrouteable address 550 Invalid sender address (in
reply to MAIL FROM command)

Reporting-MTA: dns; puma.reading.ac.uk
X-Postfix-Queue-ID: 239F850846
X-Postfix-Sender: rfc822; apm@…
Arrival-Date: Tue, 6 Mar 2018 12:59:31 +0000 (GMT)

Final-Recipient: rfc822; apm@…
Original-Recipient: rfc822;apm@localhost
Action: failed
Status: 5.0.0
Remote-MTA: dns; smtp.reading.ac.uk
Diagnostic-Code: smtp; 550-Verification failed for <apm@…>

550-Unrouteable address 550 Invalid sender address

From: apm@…
Subject: [retry] u-av351
Date: 6 March 2018 at 12:59:31 GMT
To: apm@…

Task: postproc.19670101T0000Z
Message: job failed, retrying in PT1H
See: http://puma.nerc.ac.uk/rose-bush/taskjobs/apm/u-av351

Change History (6)

comment:1 Changed 7 months ago by ros

  • Component changed from UM Model to Rose/Cylc
  • Owner changed from um_support to ros
  • Platform set to PUMA
  • Status changed from new to accepted
  • UM Version <select version> deleted

Hi Alex,

In your ~/.cylc/global.rc on PUMA you can set your email address:

[task events]
   mail to = <your-email-address> 

Alternatively, if you don't want to receive any emails about failures you will need to turn off the mail alerts in each suite. In the suite.rc file remove the --mail option from the submission, execution, etc timeouts.

Cheers,
Ros.

comment:2 Changed 7 months ago by apm

Hi Ros,

Thanks for your reply. I just checked the file you mention, and the only e-mail included is my NOC one, and it is correct.

Is there any reason you can think of that the system might assume that I have a Reading address? I would be happy to get notification of run failures, but not so happy to get constant reminders that e-mails to apm@… are being bounced!

Alex

comment:3 Changed 7 months ago by apm

Hi Ros,

Any more ideas on this one? I am still getting a dozen or so of these e-mails every day.

Thanks,

Alex

comment:4 Changed 7 months ago by ros

Hi Alex,

I'll try and take another look tomorrow, but currently can't see why that's not working. At the moment the only suggestion I have to stop the emails is as said above to remove the --mail options in the suite.rc file.

Ros.

comment:5 Changed 5 months ago by ros

Hi Alex,

This is caused by suites that are using rose suite-hook --mail, this is the old way of triggering email alerts and can cause problems on PUMA. Please remove the rose suite-hook --mail lines to stop the problems you are experiencing.

I you wish to have mail alerts you need to use the new cylc events; for example

Replace:

[cylc]
    UTC mode = True
    [[event hooks]]
        timeout handler = "rose suite-hook --mail --shutdown"

with

[cylc]
    UTC mode = True
    [[events]]
        mail events = shutdown

Cheers,
Ros.

comment:6 Changed 4 months ago by ros

  • Resolution set to answered
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.