Opened 3 months ago

Closed 7 weeks ago

#2461 closed help (fixed)

Accessing data files that are currently on MASS and transferring them to JASMIN

Reported by: charlie Owned by: um_support
Priority: normal Component: Data
Keywords: Cc:
Platform: Other UM Version:

Description

Hi,

Sorry to bother you, but I'm having trouble accessing annual mean data files that are currently on MASS and transferring them to my group workspace on JASMIN. I can access the relevant folder no problem, have found the files I want and am able to copy entire files (using moo get), but when I try to select a certain field I get the error below:

[cwilliams2011@mass-cli1 ar776.d]$ pwd
/group_workspaces/jasmin2/ncas_climate/users/cwilliams2011/data1_for_use.d/pacmedy.d/gc31n96orca1_picon.d/ar766.d
[cwilliams2011@mass-cli1 ar776.d]$
[cwilliams2011@mass-cli1 ar776.d]$
[cwilliams2011@mass-cli1 ar776.d]$ ls
pr.d queryfile_ar766_yr_pr
[cwilliams2011@mass-cli1 ar776.d]$
[cwilliams2011@mass-cli1 ar776.d]$
[cwilliams2011@mass-cli1 ar776.d]$ moo select queryfile_ar766_yr_pr moose:/crum/u-ar766/apy.pp pr.d
select command-id=545921245 failed: (SSC_TASK_REJECTION) one or more tasks are rejected.

moose:/crum/u-ar766/apy.pp → pr.d: (TSSC_QUERY_MATCHES_NO_RESULTS) no file atoms are matched by query text file.

select: failed (2)

I have, or at least I think I have, followed the instructions carefully from the Met Office wiki, but perhaps my query file is set up incorrectly? The instructions say that these stash code for the field I want (TOTAL PRECIPITATION RATE) is 5216, but this generates the above error. So does using the item number as specified by xconv.

What am I doing wrong?

Thanks,

Charlie

Change History (21)

comment:1 Changed 3 months ago by grenville

Charlie

I doubt may of us will have access to ncas_climate (I don't currently) - could you put pr.d and queryfile_ar766_yr_pr somewhere accessible?

Grenville

comment:2 Changed 3 months ago by charlie

Sorry, I have now transferred both of those to my home directory, /home/users/cwilliams2011

Charlie

comment:3 Changed 3 months ago by grenville

cd /home/users/cwilliams2011
-bash: cd: /home/users/cwilliams2011: Permission denied

Pl set the permissions

comment:4 Changed 3 months ago by charlie

Sorry, I have fully opened permissions.

comment:5 Changed 3 months ago by grenville

Charlie

This is what's in /home/users/cwilliams201queryfile_ar766_yr_pr:

begin

# 235 TOTAL PRECIPITATION RATE KG/M2/S
stash=55555216

end

Just looks like a typo

Grenville

comment:6 Changed 3 months ago by charlie

That's absolutely bizarre, because I'm 100% certain I didn't have that when I tried the file before. Nevertheless, I have now corrected the error and it works. Many thanks.

However, I now find that I can't get back on to JASMIN. Whenever I open a new terminal, I get the following error:

—-

sws06cjw@nxnode3:~/Desktop$ ssh -Y -A cwilliams2011@…

Access to this system is monitored and restricted to
authorised users. If you do not have authorisation
to use this system, you should not proceed beyond
this point and should disconnect immediately.

Unauthorised use could lead to prosecution.

(See also - http://www.stfc.ac.uk/aup)

Permission denied (publickey,gssapi-keyex,gssapi-with-mic).

—-

Whenever this has happened before, it means the ssh-agent has died and needs to be restarted. However, I have tried this:

sws06cjw@nxnode3:~/Desktop$ rm ~/.ssh/environment*
sws06cjw@nxnode3:~/Desktop$ ssh-add ~/.ssh/id_rsa_jasmin
Enter passphrase for ~/.ssh/id_rsa_jasmin:
Identity added: ~/.ssh/id_rsa_jasmin (~/.ssh/id_rsa_jasmin)

And get the same error as above.

Is there something wrong their end i.e. with JASMIN at the moment, or is it something I have done? I was able to login perfectly well this morning, and the only thing I have done since is logged into the MASS node and run various moo commands. That shouldn't change my login details from here, should it?

Charlie

comment:7 Changed 3 months ago by grenville

Charlie

Please delete the environment file - log out and login again & then ssh-add…

Grenville

comment:8 Changed 3 months ago by charlie

I did that several times yesterday. I have just done it again, i.e. I have removed the environment file, logged out (as in logout completely from NoMachine?), logged back in again, opened a new NX terminal, run ssh-add, entered my pass phrase but…. same error:

sws06cjw@nxnode4:~/Desktop$ ssh-add ~/.ssh/id_rsa_jasmin
Enter passphrase for /home/sws06cjw/.ssh/id_rsa_jasmin:
Identity added: /home/sws06cjw/.ssh/id_rsa_jasmin (/home/sws06cjw/.ssh/id_rsa_jasmin)

sws06cjw@nxnode4:~/Desktop$ ssh -Y -A cwilliams2011@…

Access to this system is monitored and restricted to
authorised users. If you do not have authorisation
to use this system, you should not proceed beyond
this point and should disconnect immediately.

Unauthorised use could lead to prosecution.

(See also - http://www.stfc.ac.uk/aup)

Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
sws06cjw@nxnode4:~/Desktop$

comment:9 Changed 3 months ago by charlie

Further to this, I have also tried logging into a different nxnode - in other words if I open a terminal normally within the VM, it logs me to nxnode4. If I then ssh into nxnode3, for example, and repeat the above process, it does at least this time say "Initialising you SSH agent" (which it didn't before) but still gives me the same permission denied error nevertheless.

comment:10 Changed 3 months ago by grenville

Have you tried ssh'ing to puma and then to jasmin?

comment:11 Changed 3 months ago by charlie

That doesn't work either - I can ssh into Puma no problem, but then get the same error when trying to ssh into Jasmin. I have tried removing the environment file on Puma and reinitialising the agent, but same error every time.

comment:12 Changed 3 months ago by andy

Hi Charlie,

Could you try:
eval $(ssh-agent)

Then ssh-add

and then try to ssh -A to jasmin-login1.ceda.ac.uk

comment:13 Changed 3 months ago by charlie

Hi Andy,

Just tried that on both nxnode4 and Puma, and same permission denied error every time. See below.

As I said to Grenville (comment 6 above), this was working absolutely fine yesterday morning. The only one thing that has changed is that I then registered to get access from Jasmin to MASS, and transferred some data across using various moo commands. I did this yesterday morning, and ever since then have been unable to get back onto Jasmin. Are these connected, or is it complete coincidence? I only ask because, as part of the installation process (according to the MO wiki), I had to run the moo install command on Jasmin. Would this, or could this, have done anything to my existing setup and keys?

Charlie

sws06cjw@nxnode4:~/Desktop$ eval $(ssh-agent)
Agent pid 109664
sws06cjw@nxnode4:~/Desktop$ ssh-add ~/.ssh/id_rsa_jasmin
Enter passphrase for /home/sws06cjw/.ssh/id_rsa_jasmin:
Identity added: /home/sws06cjw/.ssh/id_rsa_jasmin (/home/sws06cjw/.ssh/id_rsa_jasmin)
sws06cjw@nxnode4:~/Desktop$ ssh -Y -A cwilliams2011@…

Access to this system is monitored and restricted to
authorised users. If you do not have authorisation
to use this system, you should not proceed beyond
this point and should disconnect immediately.

Unauthorised use could lead to prosecution.

(See also - http://www.stfc.ac.uk/aup)

Permission denied (publickey,gssapi-keyex,gssapi-with-mic).

or

charlie@puma:/home/charlie> eval $(ssh-agent)
Agent pid 4941
charlie@puma:/home/charlie> ssh-add .ssh/id_rsa_jasmin
Enter passphrase for .ssh/id_rsa_jasmin:
Identity added: .ssh/id_rsa_jasmin (.ssh/id_rsa_jasmin)
charlie@puma:/home/charlie> ssh -Y -A cwilliams2011@…

Access to this system is monitored and restricted to
authorised users. If you do not have authorisation
to use this system, you should not proceed beyond
this point and should disconnect immediately.

Unauthorised use could lead to prosecution.

(See also - http://www.stfc.ac.uk/aup)

Permission denied (publickey,gssapi-keyex,gssapi-with-mic).

comment:14 Changed 3 months ago by andy

Hi Charlie,

Has your jasmin login right expired? Try emailing the CEDA help desk to check this. I cannot see anything has wrong as what you are trying looks okay to me.

Cheers
Andy

comment:15 Changed 3 months ago by charlie

Not according to the Jasmin group workspaces website, where I am registered to the jasmin-login service and which doesn't expire until 29 September 2019.

comment:16 Changed 3 months ago by charlie

A thought: the only other thing I did yesterday was opened up all my permissions on Jasmin in my home directory, so that Grenville could see my files and solve my original question (which started this thread). Might this have anything to do with my current lack of access? I vaguely remember something like this happening before, but don't remember why or what we did about it.

comment:17 Changed 3 months ago by andy

Hi Charlie,

You have world write access to your jasmin@CEDA home directory! You'll need to restrict this a little:

chmod 755 ~

Your .ssh directory is 700 which is correct.

Once you've done the above try logging in again from nxnode4.

comment:18 Changed 3 months ago by charlie

But how do I change permissions in my Jasmin directory if I can't log into it?

comment:19 Changed 3 months ago by andy

Yes, you'll have to ask CEDA to do that for you…

comment:20 Changed 3 months ago by charlie

Ok… for posterity, it would seem that the problem is entirely my fault, because I opened up permissions to allow Grenville access to my home account. I clearly opened up permissions too far, because I made it world write access. I have just heard from the Jasmin helpdesk and that's the reason. They have now changed my account back to how it was, and I can login fine. Sorry for the schoolboy mistake.

In the future, rather than opening up permissions on my entire account, if I want one you to look at a certain file, what should I do to give access to this?

comment:21 Changed 7 weeks ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.