Opened 4 months ago

Closed 3 months ago

#2483 closed help (fixed)

Problem running UM with Arctic CORDEX domain

Reported by: anmcr Owned by: um_support
Priority: highest Component: UM Mesoscale
Keywords: nested suite, Arctic Cc: stuart.webster@…
Platform: Monsoon2 UM Version: 10.4

Description

Hi Willie (cc Stu),

I am trying to run the UM nested suite with the Arctic CORDEX domain (e.g. http://www.cordex.org/domains/region-11-arctic/). The model id is u-ax839. This involves centering a rotated domain more-or-less over the north pole. Unfortunately, this is creating a problem with the model. For example, the orography and land mask ancillaries are corrupted. See attachment. Is there anyway around this?

Many thanks for any help.

Andrew


Attachments (3)

Arctic_CORDEX_orography.png (569.9 KB) - added by anmcr 4 months ago.
Orography ancillary for Arctic CORDEX domain
for greville.PNG (223.2 KB) - added by anmcr 4 months ago.
for ros.PNG (73.8 KB) - added by anmcr 3 months ago.

Download all attachments as: .zip

Change History (19)

Changed 4 months ago by anmcr

Orography ancillary for Arctic CORDEX domain

comment:1 Changed 4 months ago by willie

Hi Andrew,

The problem is not with the UM but with the CAP. It has failed to produce a proper mask, orography or land fraction ancillaries. The rest of the ancillaries are based on these and will be wrong too.

You could try upgrading to version 9.1 of the CAP. I think all you have to do is to change the version number VN at the bottom of the app ancil_mask > env. Do this for each app of the ancil_<app> tasks. The rebuild and run it.

Regards
Willie

comment:2 Changed 4 months ago by anmcr

Hi Willie,

Thanks for the feedback. Stu Webster is looking at the problem with the CAP. Could you please help with another couple of problems that I am having getting this run to work? My run ID is u-ax832.

i) I'm having difficulty saving my output in $DATADIR, and currently the only way I can get the model to run is to save this on $SCRATCH, ie by setting 'root-dir=*=$SCRATCH' in rose-suite.conf.

ii) The model failed at the 'glm_um_recon1' stage, with the error

Error message: PR_FIXHD: Consistency check
? Invalid sub-model indicator: Fixed Length Header(2) = 57726013079424
? Please see UMDP F03 for details of appropriate values.
? Error from processor: 0
? Error number: 2

I have never come across this error before, and unsure what is causing it.

Best wishes,

Andrew

comment:3 Changed 4 months ago by willie

Hi Andrew,

If you're using a GRIB file to start the global model, then you need to select glm_um→ namelist → Reconfig and Anc Control → General Technical options and tick the GRIB button there.

I'm not sure about the DATADIR problem. This might be one for the Monsoon Help desk. What are the details?

Regards
Willie

comment:4 Changed 4 months ago by anmcr

Hi Willie,

If I set 'root-dir=*=$DATADIR' and 'root-dir{share/cycle}=*=$DATADIR' in rose-suite.conf then I get the error 'Permission denied: '/projects/cascade/amworr/cylc-run/u-ax832' when I try to run the model. It evidently thinks that my $DATADIR directory is /projects/cascade/amworr and not/projects/polar/amworr.

Thanks for the help.

Andrew

comment:5 Changed 4 months ago by grenville

Andrew

pl see ticket 2442

Grenville

comment:6 Changed 4 months ago by anmcr

Hi Grenville and Willie,

Many thanks for the help. The suggestion from ticket #2442 worked, and the model submitted successfully. (I actually tried this suggestion last week, so I'm not sure why it should work now.)

Anyway, the model now fails again on glm/glm_um_recon/glm_um_recon1 with the error 'Section 0 Item 9 Required field is not in input dump!'. This field is 'soil moisture content in a layer'. Is this because I am forcing the global model with ERA-Interim reanalysis, which does not have all of the necessary fields to force the model?

The output file for the error is /home/d01/amworr/cylc-run/u-ax832/log/job/19901101T0000Z/glm_um_recon1/01

Andrew


comment:7 Changed 4 months ago by anmcr

Hi Grenville,

My model won't submit again (u-ax832). I have attached an image of the 'no hosts selected' error, and confirmation that I am following your suggestion from ticket #2442 about setting root-dir{share} and root-dir{work}. Are you able to please advise?

Thanks,

Andrew

Changed 4 months ago by anmcr

comment:8 Changed 4 months ago by anmcr

With attachment

comment:9 Changed 4 months ago by ros

Hi Andrew,

rose host-select postproc currently doesn't work on Monsoon.

For the moment in site/monsoon-cray-xc40 please change:

host = $(rose host-select {{IDL_SERVER}})

to

host = {{IDL_SERVER}}

Cheers
Ros

comment:10 Changed 3 months ago by anmcr

Dear Ros,

I'm just returning from holiday.

Could you please tell me where I find 'site/monsoon-cray-xc40'?

Thanks,

Andrew

comment:11 Changed 3 months ago by ros

Hi Andrew,

It's in the suite: ~/roses/<suiteid>/site/monsoon-cray-xc40

Cheers,
Ros.

comment:12 Changed 3 months ago by anmcr

Dear Ros,

Thanks for the reply. I've made the change you suggested at /home/d01/amworr/roses/u-ax832/site/monsoon-cray-xc40. However, I now have another error saying: Cannot allocate memory: 'rsync'. See attachment. I couldn't find a previous ticket concerning this error. Are you please able to help?

Thanks,

Andrew


Changed 3 months ago by anmcr

comment:13 Changed 3 months ago by anmcr

Hi Ros,
I quit the job, and then reloaded it.
It seems to have submitted successfully now.
Andrew

comment:14 Changed 3 months ago by anmcr

Hi Willie,

Job id u-ax832

I have a further error with the global model reconfiguration. See below. It is asking for the field 'dust parent soil clay fraction'. This is in the ancillary file qrparm.soil.dust, which I have not loaded. Can I deactivate any soil.dust related physics in the model to get around this problem? If so, could you please tell me how to do this?

Many thanks,

Andrew

????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!
? Error code: 30
? Error from routine: RCF_RESET_DATA_SOURCE
? Error message: Section 0 Item 418 : Required field is not in input dump!
? Error from processor: 0
? Error number: 4
????????????????????????????????????????????????????????????????????????????????

comment:15 Changed 3 months ago by anmcr

Hi Willie, Ros, and Grenville,

Thanks for the help. I've managed to get the model working.

Please close this ticket.

Andrew

comment:16 Changed 3 months ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.