Opened 12 days ago

Last modified 4 days ago

#2483 new help

Problem running UM with Arctic CORDEX domain

Reported by: anmcr Owned by: um_support
Priority: highest Component: UM Mesoscale
Keywords: nested suite, Arctic Cc: stuart.webster@…
Platform: Monsoon2 UM Version: 10.4

Description

Hi Willie (cc Stu),

I am trying to run the UM nested suite with the Arctic CORDEX domain (e.g. http://www.cordex.org/domains/region-11-arctic/). The model id is u-ax839. This involves centering a rotated domain more-or-less over the north pole. Unfortunately, this is creating a problem with the model. For example, the orography and land mask ancillaries are corrupted. See attachment. Is there anyway around this?

Many thanks for any help.

Andrew


Attachments (1)

Arctic_CORDEX_orography.png (569.9 KB) - added by anmcr 12 days ago.
Orography ancillary for Arctic CORDEX domain

Download all attachments as: .zip

Change History (7)

Changed 12 days ago by anmcr

Orography ancillary for Arctic CORDEX domain

comment:1 Changed 8 days ago by willie

Hi Andrew,

The problem is not with the UM but with the CAP. It has failed to produce a proper mask, orography or land fraction ancillaries. The rest of the ancillaries are based on these and will be wrong too.

You could try upgrading to version 9.1 of the CAP. I think all you have to do is to change the version number VN at the bottom of the app ancil_mask > env. Do this for each app of the ancil_<app> tasks. The rebuild and run it.

Regards
Willie

comment:2 Changed 4 days ago by anmcr

Hi Willie,

Thanks for the feedback. Stu Webster is looking at the problem with the CAP. Could you please help with another couple of problems that I am having getting this run to work? My run ID is u-ax832.

i) I'm having difficulty saving my output in $DATADIR, and currently the only way I can get the model to run is to save this on $SCRATCH, ie by setting 'root-dir=*=$SCRATCH' in rose-suite.conf.

ii) The model failed at the 'glm_um_recon1' stage, with the error

Error message: PR_FIXHD: Consistency check
? Invalid sub-model indicator: Fixed Length Header(2) = 57726013079424
? Please see UMDP F03 for details of appropriate values.
? Error from processor: 0
? Error number: 2

I have never come across this error before, and unsure what is causing it.

Best wishes,

Andrew

comment:3 Changed 4 days ago by willie

Hi Andrew,

If you're using a GRIB file to start the global model, then you need to select glm_um→ namelist → Reconfig and Anc Control → General Technical options and tick the GRIB button there.

I'm not sure about the DATADIR problem. This might be one for the Monsoon Help desk. What are the details?

Regards
Willie

comment:4 Changed 4 days ago by anmcr

Hi Willie,

If I set 'root-dir=*=$DATADIR' and 'root-dir{share/cycle}=*=$DATADIR' in rose-suite.conf then I get the error 'Permission denied: '/projects/cascade/amworr/cylc-run/u-ax832' when I try to run the model. It evidently thinks that my $DATADIR directory is /projects/cascade/amworr and not/projects/polar/amworr.

Thanks for the help.

Andrew

comment:5 Changed 4 days ago by grenville

Andrew

pl see ticket 2442

Grenville

comment:6 Changed 4 days ago by anmcr

Hi Grenville and Willie,

Many thanks for the help. The suggestion from ticket #2442 worked, and the model submitted successfully. (I actually tried this suggestion last week, so I'm not sure why it should work now.)

Anyway, the model now fails again on glm/glm_um_recon/glm_um_recon1 with the error 'Section 0 Item 9 Required field is not in input dump!'. This field is 'soil moisture content in a layer'. Is this because I am forcing the global model with ERA-Interim reanalysis, which does not have all of the necessary fields to force the model?

The output file for the error is /home/d01/amworr/cylc-run/u-ax832/log/job/19901101T0000Z/glm_um_recon1/01

Andrew


Note: See TracTickets for help on using tickets.