Opened 11 years ago

Closed 11 years ago

#251 closed help (fixed)

ancil file causing fatal error in recon

Reported by: mjm Owned by: jeff
Component: UM Model Keywords:
Cc: Platform:
UM Version: 4.5

Description

Hello

Using the UM on ECDF, a recon falls over and the leave file says:

LOOKUP TABLE

10560 64-bit words long


Warning : Ozone data is zonal in both input and output dumps.
If an ozone ancillary file is not provided,
output data is interpolated from input data.


Ancillary data file 5 , unit no 34 ,

VEGETATION TYPE



FIXED LENGTH HEADER
—————————-
Dump format version
UM Version No

*FATAL ERROR* Invalid data type: FIXHD(2)=*
ERROR in READHEAD for Ancillary File 5
Unit Number 34


Error detected in subroutine INANCILA INANCILA ANCILLARY NOT IN THIS CONFIGURATION Sea-surface temp

PR_FIXHD: Consistency check

ICODE= 4

1+1 records in
1+1 records out

I am puzzled by the apparently invalid header, so may I ask:

  1. Any guidance to offer about that?
  1. Is there a way to check the validity of the ancil file please?

(The file is $UM_ANCIL_SAGES/STh3NatA/qrparm.veg.1749, where
UM_ANCIL_SAGES = )

Regards
Mike Mineter

_ _

Change History (2)

comment:1 Changed 11 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to accepted

Hi Mike

I assume qrparm.veg.1749 is the file in /exports/work/geos_sages/um/ancil_sages/STh3NatA. The problem is this file is little endian but the UM needs to read in big endian data. Where did this file come from? You can use bigend -64 file1 file2 to byte swap the data. This won't work if the file uses packing but I think this file should be okay. If you look at the file with xconv it says

file /exports/work/geos_sages/um/ancil_sages/STh3NatA/qrparm.veg.1749 is a 64 bit ieee um file

whereas if you look at one of the other ancillaries for this job you get

file /exports/work/geos_sages/CESD/um/vn4.5/ancil/atmos/cl_9673/qrclim.sst is a byte swapped 64 bit ieee um file

As eddie is a little endian machine this means the veg file is little endian and the sst file is big endian.

Jeff.

comment:2 Changed 11 years ago by jeff

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.