#2550 closed help (fixed)

Ancillary file issues

Reported by: laurahb Owned by: um_support
Component: UM Model Keywords:
Cc: Platform:
UM Version:

Description

I've created my own SST and sea-ice ancillaries from HadISST data (using xancil), and tried to use them in my run u-ay059. It's coming up with errors as follows:

Error from routine: UP_ANCIL
Error message: REPLANCA: I/O ERROR

so I'm assuming it's a problem with my ancillary files. They look fine in xconv so I'm not sure how to find out what the problem might be.
One possible problem could be that they run from November 1975 to October 1976 but my model run isn't for those dates (because I'm prescribing the SSTs etc the actual start date etc doesn't matter, so it's currently running 1981 and I intend to run 10 years using these same SST/sea-ice to get 10 realisations of 1975-6). I was hoping that it would just keep cycling through the months and ignore the year in the ancil files - is this correct? Or if not, is there a way round it (e.g. creating the ancil file specifically as a cycling one)?
Other than that I've seen other tickets where people had problems with the lats being the wrong way round, so it's possible that could have happened here. I've tried (and failed) to find the directories where the standard ancil files are stored so I can try to compare mine but so far had no luck finding them.
Any thoughts on what the cause of the error is?
My ancil files are here:
/work/n02/n02/lbaker/ancil_files/HadISST_ice_nov75_oct76 and HadISST_sst_nov75_oct76

Change History (5)

comment:1 Changed 13 months ago by grenville

lot of ancil files are under here:

/work/y07/y07/umshared/ancil

comment:2 Changed 13 months ago by grenville

Your latitudes are indeed inverted - rerun xancil with a later version (10.3 for your suite) in the General configuration section (see http://cms.ncas.ac.uk/documents/xancil/index.html.)

Grenville

comment:3 Changed 13 months ago by laurahb

Thanks, I was sure I had changed the version but apparently not!
I've also noticed that the grid is different from that of an equivalent standard ancil (offset by 0.9375 long/0.625 lat). Does this matter? If so I'll have to redo the nc file regridding.
Also about the dates: does the year matter or will the UM just cycle through the months regardless of year?

comment:4 Changed 13 months ago by grenville

Laura

I believe the ancillary file should be on the target grid and that the year does not matter for a climatology.

Grenville

comment:5 Changed 12 months ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.