#2571 closed help (fixed)

No module named um_utils.fixframe

Reported by: nx902220 Owned by: ros
Component: Monsoon Keywords:
Cc: Platform:
UM Version: 10.5

Description

Hi,

Since last week my suite u-az169 has been failing at ukv_start and I do not think I have made any changes to the suite which would have caused the error.

Do you know if fixframe has changed?

The error message is below:

Killed by signal 15.
WARNING:
This computer is provided for the processing of official information.
Unauthorised access described in Met Office SyOps? may constitute a criminal offence.
All activity on the system is liable to monitoring.
Traceback (most recent call last):

File "/projects/um1/bin/mule-fixframe", line 9, in <module>

load_entry_point('um-utils==2017.08.1', 'console_scripts', 'mule-fixframe')()

File "/opt/python/gnu/2.7.9/lib/python2.7/site-packages/distribute-0.6.28-py2.7.egg/pkg_resources.py", line 337, in load_entry_point

return get_distribution(dist).load_entry_point(group, name)

File "/opt/python/gnu/2.7.9/lib/python2.7/site-packages/distribute-0.6.28-py2.7.egg/pkg_resources.py", line 2311, in load_entry_point

return ep.load()

File "/opt/python/gnu/2.7.9/lib/python2.7/site-packages/distribute-0.6.28-py2.7.egg/pkg_resources.py", line 2017, in load

entry = import(self.module_name, globals(),globals(), __name__?)

ImportError?: No module named um_utils.fixframe
2018-08-08T12:05:07Z CRITICAL - failed/EXIT

Best wishes,

Lewis

Change History (6)

comment:1 Changed 16 months ago by ros

Hi Lewis,

A python directory appears to have gone walkies on the XCS which I believe is the cause of your problem. I've emailed the Met Office to determine what's going on.

Cheers,
Ros

comment:2 Changed 16 months ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Lewis,

You now need to load the scitools module to gain access to the the python tools.

In ~/roses/u-az169/suite.rc add an extra module load line to the pre-script= in the [[XCD]] section:

module load scitools

Cheers,
Ros.

comment:3 Changed 16 months ago by nx902220

Hi Ros,

I have done what you suggest but it fails with the same error message.

Cheers,

Lewis

comment:4 Changed 16 months ago by willie

Hi Lewis,

The mule utilities are no longer in $UMDIR/bin but are set up in the scitools module. So you also need to modify the retrieve_ukv_data script in your suite, by replacing $UMDIR/bin/mule-fixframe with mule-fixframe.

Willie

comment:5 Changed 16 months ago by nx902220

Hi Ros, Willie,

After following comment 4 I no longer get the error.

Thanks,

Lewis

comment:6 Changed 16 months ago by willie

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.