#2581 closed help (fixed)

CMIP6 MH production run failing because of unrecognised stash item

Reported by: charlie Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 10.7

Description

Hi,

Please can you advise on the following error? My suite is u-ba469, and it is the beginning of the CMIP6 mid-Holocene production run (i.e. it restarts from the endpoint of my spin-up suite). In this suite, I have changed the stash table (from a minimal stash to the full stash), importing the full stash table from the preindustrial control suite. However, I'm getting the error below. Clearly this is a problem with one of the stash items, but it doesn't tell me which one?

Please can you help?

Charlie

????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!!       ERROR        ???!!!???!!!???!!!???!!!???!!!
?  Error code: 18
?  Error from routine: rdbasis
?  Error message: UNRECOGNISED usage profile request UP7
?  Error from processor: 0
?  Error number: 10
????????????????????????????????????????????????????????????????????????????????

Change History (8)

comment:1 Changed 14 months ago by charlie

Further to this: I'm now had a closer look at my stash table within Rose, and there are indeed 50 or so fields using the UP7 profile which are all part of the CMIP6-core package (one of the ones switched on when I imported the new table). All of these appear to use either the T6HR or T6HRMN time profile, which are both defined okay as far as I can tell, as well as various domain profiles which again look okay. So why is it not liking this profile?

comment:2 Changed 14 months ago by ros

Hi Charlie,

What exactly did you do to change your stash table in this suite? Under the "usage profiles" in rose edit there is no UP7 usage profile defined that I can see…..

Cheers,
Ros.

comment:3 Changed 14 months ago by charlie

Hi Ros,

I imported the stash from Till's preindustrial control production run (which is copied under my directory as u-at479), using the following instructions (from my Idiot's guide, based on previous directions from you):

1) Export source suite stash by going into /home/<userID>/roses/<suiteID>app/um and running rose macro stash_copy.STASHExport.  Choose default values.  This will generate a file called STASHexport.ini
2) Move this file into target suite (i.e. /home/<userID>/roses/<suiteID>app/um, where suiteID = the suite wanting to be changed)
3) Rename this file: mv STASHexport.ini STASHImport.ini
4) The import macro only adds to an existing suite’s stash table, it doesn’t overwrite it completely.  So, before importing, need to delete existing table, in /home/<userID>/roses/<suiteID>app/um/rose-app.conf.  Need to delete all stash requests (*streq), as well as time, usage, & domain items (probably don’t need to remove these, but no harm in doing so).  Need to remove entire thing, e.g. [namelist:umstash_streq(00002_28c09)
5) Once saved, check within Rose - the stash table should now be empty
6) Import the previously exported stash table by running rose macro stash_copy.STASHImport, again choosing default values
7) Check it has worked.  Within Rose, the stash table should now contain new items.  Still within this window, run 2 macros: stashtestmask.stashTstmskValidate (which will check that the stash configuration is suitable for this UM configuration) and stash_indices.TidyStashTransform (which will tidy up any out of place items).  It’s possible that some items will have red warning triangles, which is likely because they are not suitable for this particular configuration - these should be changed so that they are ignored.  Also, back at command line (still within /app/um), run rose macro --validate to check for other issues.  Another way of checking is to look at actual number of items within rose-app.conf for each directory (i.e. original and new) by using grep umstash_streq rose-app.conf | wc -l.  This number should be the same for both.  Note: when exporting/importing, the number it reads through will not be the same as this number. 

Charlie

comment:4 Changed 14 months ago by ros

Hi Charlie,

The STASH macro to generate the hashes for the STASH namelist items (ie the new usage profiles) has not been run in Till's suite, thus the STASHexport macro has ignored all the new usage profiles. Open up Till's suite with rose edit and run the macro by going to "Metadata → um → um/stash_indices.TidyStashTransform.transform". You can then follow your instructions and export the stash.

Before you import the STASH check the STASHexport.ini file to make sure that there is a namelist entry for UP7. It will be something like:

[namelist:umstash_use(up7_b3b8b788)]
file_id='pp118'
locn=3
!!macrotag=0
use_name='UP7'

Regards,
Ros.

Last edited 14 months ago by ros (previous) (diff)

comment:5 Changed 14 months ago by charlie

Hi Ros,

Okay, I have done as you suggested, running the macro within Till's suite and then repeating the steps as before (I deleted the existing STASHexport.ini and STASHImport.ini before beginning, so starting from afresh). I have now resubmitted my suite, so fingers crossed it will start running.

However, I'm a little confused. You said you couldn't see any UP7 profiles within Rose, however when I checked the previous STASHImport.ini (i.e. before I deleted it) and search for UP7, there were lots of profiles. Likewise when I checked the early previous of my rose-app.conf again there were lots of UP7 entries, all similar to:

[namelist:umstash_streq(00409_aa03092c)]
dom_name='DIAG'
isec=0
item=409
package='CMIP6-core'
tim_name='T6HRMN'
use_name='UP7'

So if these were indeed listed the first time I tried this, why did it fail?

Charlie

comment:6 Changed 14 months ago by ros

Hi Charlie,

The UP7 entries you could see in the rose-app.conf are not the specification of what the usage profile UP7 is. These entries are the individual stash requests that you see listed in the big table in rose edit where you specify which time, domain and usage profile that diagnostic is to be output on. You then obviously have to define what the time, domain and usage profiles actually are. This was the bit that was missing for UP7 (ie. an entry in the namelist umstash_use that I gave as an example in my previous comment). In rose edit all valid usage profiles are listed in the "Usage Profiles" panel, similarly for the Time and Domain profiles.

Cheers,
Ros.

comment:7 Changed 14 months ago by charlie

Oh okay, I understand now. It appears to be running, or at least it started an hour ago and is still going. Many thanks, I think this ticket can be closed.

comment:8 Changed 14 months ago by charlie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.