Opened 12 years ago

Closed 12 years ago

#260 closed help (fixed)

Error 2 in 1km UM run

Reported by: bethan.white Owned by: willie
Component: UM Model Keywords: prognostic rain, LBC
Cc: Platform:
UM Version: 6.1

Description

Hi, I am currently trying to run a 1km job (xdsvt) using lbcs from a previous 4km job that Willie set up for me (xdsvr).

I am getting Error 2:

Wrong number of LBC variables found in LBC file
Expecting record 15 to contain STASH item code 31002
But found item code 31020

UM ERROR (Model aborting) :
Routine generating error: inbounda
Error code: 2
Error message:
Error in CHK_LOOK_BOUNDA
*

I previously experienced this error with a 4km job; Humphrey Lean kindly gave me the hand edit lmurklbc_true and modsets afr5h602_murklbc.mh and afr5f602_murklbc_v2.mf77 to allow version 6.6 to read murk from the lbcs. I have included these in my setup but I am wondering whether the problem is that these files won't work at 1km?

Thanks,
Bethan.

Change History (3)

comment:1 Changed 12 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to accepted

Hi Bethan,

Your new LBC file has a prognostic rain field in it (the 4km standard LBC doesn't) and you need to tell the model about this: check "Input LBCs include prognostic rain" in Atmosphere > Ancillary and Inoput > Other > lateral Boundary conditions in the UMUI. This will get you past the first error.

My run then failed due to MPI errors - see
http://ncas-cms.nerc.ac.uk/content/view/1412/43/ for advice. I set MPICH_PTL_OTHER_EVENTS to 90,000 and this cleared the errors. The run was then terminated due to running out of time, so you may need to increase this.

Other things you may need to consider are,

  1. the modsets are only invoked if the option to compile is selected
  2. the onekm modset does not exist - I just swicthed this off
  3. the modsets labelled afr* are also present in HRTM/base, so I switched the afr* off.

I think it should work now. If you have any further problems please let me know.

Regards,

Willie

comment:2 Changed 12 years ago by bethan.white

Hi Willie,

Thank you for all your help with this. I have had the job time out on the 20 minute queue with no errors, so it looks like it will work. I have put it on a longer queue to let it run.

Thanks again for your help getting this working,
Bethan.

comment:3 Changed 12 years ago by willie

  • Keywords prognostic rain, LBC added
  • Resolution set to fixed
  • Status changed from accepted to closed
  • UM Version set to 6.1
Note: See TracTickets for help on using tickets.