Opened 11 years ago

Closed 11 years ago

#264 closed help (fixed)

Hector not responding to submit button from UMUI job

Reported by: chollow Owned by: ros
Component: UMUI Keywords: Hector submit UMUI puma
Cc: Platform:
UM Version: 7.1

Description

Hi, I've submitted jobs to Hector in the past few months with no problem, but now after I hit the submit button, when it says it is setting up submit scripts on remote machine, it hangs a while and then I get the following error and stack trace:

ERROR: Timed out, login.hector.ac.uk not responding
STACK-TRACE:
Timed out, login.hector.ac.uk not responding

while executing

"error $err"

(procedure "um_nav_submit" line 18)
invoked from within

"um_nav_submit"

(command bound to event)

I don't think this is a problem with passwordless ssh since I set that up successfully before and I am still able to ssh to hector from puma with no password.

I also looked at a previous ticket which referred me to a webpage here, but when I tried the command: "export UMUI_SSH_DEBUG_LEVEL-1" before starting UMUI, I did not get any error messages on the terminal.

Thanks,
Chris

Change History (2)

comment:1 Changed 11 years ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Chris,

Can you tell me if you are still unable to submit jobs to HECToR? I've tried my 7.1 job this morning and it's working ok for me.

Cheers,
Ros.

comment:2 Changed 11 years ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed

The debug information showed by setting UMUI_SSH_DEBUG_LEVEL=1 indicated that the process was waiting for comfirmation to delete a file on HECToR. This was caused by Chris having an alias for rm to put it in interactive mode (rm -i). Taking this alias out of the .profile fixed this problem.

Another solution might be to change the SUBMIT script so that all rm commands are rm -f which would override a user's setting. This would need to be investigated; if there are any rm -r commands this would probably not be a safe thing to do.

Note: See TracTickets for help on using tickets.