Opened 12 years ago

Closed 11 years ago

#265 closed help (fixed)

using LAMPOS

Reported by: mjm Owned by: willie
Component: UM Mesoscale Keywords: LAMPOS HadRM3
Cc: r.essery@…, w.mcginty@… Platform:
UM Version: 4.5

Description

We installed LAMPOS on our cluster, ECDF, following the LAMPOS web page (setting alias, using $HOME/lampos).

  1. When the window opens there is no grid. Therefore,
  1. We tried to load a grid from a previous job, which for us meant that we created a ~/umui_jobs/xdukb directory and copied SIZES into it.

child process exited abnormally
child process exited abnormally

while executing

"exec grep -i EWSPACEA= $file | perl -pe s{.*EWSPACEA=\\s*(\\S+),.*}{\\1}i"

(procedure "getgridfromjob" line 57)
invoked from within

"getgridfromjob"

invoked from within

".view.rd.scr.lw.apply invoke"

("uplevel" body line 1)
invoked from within

"uplevel #0 [list $w invoke]"

(procedure "tk::ButtonUp?" line 22)
invoked from within

"tk::ButtonUp? .view.rd.scr.lw.apply"

(command bound to event)

We also tried installing LAMPOS on PUMA, but it rejected the processor type "athlon". Next we tried to use lampos_i386 directly, avoiding the top script, also failed as follows:
mjm@puma:/export/puma/data-01/home/mjm> cd lampos
mjm@puma:/export/puma/data-01/home/mjm/lampos> lampos_i386/lampos
lampos.tcl
Error in startup script: couldn't execute "../../bin/lltoeq.exec": no such file or directory

while executing

"open "|echo $scale $plon $plat $xshift $yshift $coast | ../../bin/lltoeq.exec" r "

(procedure "drawmap" line 21)
invoked from within

"drawmap"

(procedure "main" line 272)
invoked from within

"main"

(file "lampos_i386/lampos.tcl" line 31)

So our questions are:

  1. is it better to have this on PUMA or on our own cluster?
  1. Can you give guidance to help it work on one or the other, please.

Regards
Mike

Change History (5)

comment:1 Changed 12 years ago by lois

  • Cc w.mchinty@… added; m.mineter@… removed

Hello Mike,

William McGinty? recently installed lampos on PUMA and I have just checked and all seems ok for me. It is avaialable here

/home/umui/lampos/lampos

I am not sure why you can't build it on your own cluster, William will be able to answer this when he returns from holiday next week. So I will keep this query open for William to advise you on getting lampos to work on the cluster if that is what you want. In the mean time use lampos on PUMA.

Lois

comment:2 Changed 12 years ago by willie

  • Cc w.mcginty@… added; w.mchinty@… removed
  • Owner changed from um_support to willie
  • Status changed from new to assigned

Hi Mike,

You should just be able to type lampos on PUMA and it should work now.

To install on your own machine, you need Tcl and perl. Can you confirm that you have these?

Regards,

Willie

comment:3 Changed 12 years ago by mjm

Thanks Lois and Willie for help with this.

Willie - we do have tcl and perl. (Apologies for being slow to respond - am working on site away from home.)

Is it better for us to have Lampos on our own cluster as well as PUMA - or is PUMA alone sufficient?

Regards Mike

comment:4 Changed 12 years ago by willie

Hi Mike,

PUMA should be enough as LAMPOS is only providing a few details to set up the LAM and the UMUI runs on PUMA too.

The reason for all the errors on your machine is that the perl command can't be found, so perhaps you just need to add it to your PATH on your machine.

Regards,

Willie

comment:5 Changed 11 years ago by willie

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.