#2656 closed help (fixed)

File transfer from exvmsrose to a local machine

Reported by: jokea Owned by: ros
Component: Monsoon Keywords: Login, exvmsrose, lander
Cc: Platform: Monsoon2
UM Version:

Description

Hi,

I'm looking for a way to transfer UM output files from Monsoon to my local machine.

Up to now, I was doing this by logging into Monsoon and setting up a tunnel to my machine at Exeter University, but now I'm working remotely from my laptop and need to find another way.

Since ssh is not set up on my laptop for incoming connections, I'd like to find a way to set up a tunnel between lander and exvmsrose and then pull the files directly from exvmsrose. I don't think I can move them to lander's /staging because there does not appear to be enough space there (each of my directories is around 17G).

A little googling revealed a way to tunnel to exvmsrose by adding the following to .ssh/config on my local machine:

Host exvmsrose.monsoon-metoffice.co.uk
  User          jokea
  HostName      exvmsrose.monsoon-metoffice.co.uk
  ProxyCommand  ssh jokea@lander.monsoon-metoffice.co.uk nc %h %p 2> /dev/null

Then if run:

ssh -Y jokea@exvmsrose.monsoon-metoffice.co.uk

on my laptop, I am prompted for my key-fob code. The problem is that after I enter the keyfob code, I am then prompted for a password for exvmsrose. Since access to exvmsrose from lander is already setup using ssh keys, I do not know this password.

Is there a way to either 1) obtain the password for exvmsrose, or 2) use scp on my local machine to directly pull files from exvmsrose (and therefore bypass lander) by some other means?

Thanks,
John

Change History (7)

comment:1 Changed 13 months ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi John,

Please see instructions on the collaboration wiki - How to copy files into and out of Monsoon: https://collab.metoffice.gov.uk/twiki/bin/view/Support/MONSooNFAQs

Just to say exvmsrose is the same filesystem as the xcs so you copy them from the xcs (not exvmsrose).
Hope this helps.

Regards,
Ros.

comment:2 Changed 13 months ago by jokea

Hi Ros,

Thanks, I had actually missed the part of that document about indirect transfer on first glance. It's quite similar to what I was doing before anyway.

However, the problem remains — xcs-c wants a password that I don't have. For example, if I issue the command:

scp -o "ProxyCommand ssh jokea@lander.monsoon-metoffice.co.uk exec nc %h %p 2>/dev/null" xcs-c:/home/d04/jokea/cylc-run/u-bc310/share/cycle/20170709T0000Z/Regn1/resn_1p5km/RA1M/um/umnsa.stash . 

Then monsoon will return

Enter PASSCODE:

And when I enter the PASSCODE using my fob, monsoon asks for

Password:

Is there a way to make Monsoon aware of the ssh keys (which I believe come from ~/.ssh/known_hosts and ~/.Xauthority on lander), and if not, can I get this password from someone?

comment:3 Changed 13 months ago by ros

Hi John,

I'll try this out myself and get back to you once I've got it working. There is no password so that won't help unfortunately.

Regards,
Ros.

comment:4 Changed 13 months ago by ros

John,

Just looking at those instructions did you try the tar based method too as it explicitly says if you have problems being asked for password try the tar based method?

CHeers,
Ros.

comment:5 Changed 13 months ago by ros

Hi John,

Further to this I confirm the tar based method works OK.

Regards,
Ros.

comment:6 Changed 13 months ago by jokea

Ros,

Ah yes, working now. Classic case of not reading the docs properly.

Thanks for your help!

comment:7 Changed 13 months ago by jokea

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.