Opened 3 weeks ago

Closed 6 days ago

#2659 closed help (fixed)

fcm_make_um failing

Reported by: ChrisWells Owned by: um_support
Priority: normal Component: UM Model
Keywords: Cc:
Platform: Monsoon2 UM Version:

Description

Hi,

I tried to run the um vn10.9 for the first time in a while. I copied a working suite (copied u-ba441 to u-bc512; the emissions files for u-ba441 have been moved), changed the emissions and year, and submitted, but got the error

[FAIL] extract.location{primary}[um] = fcm:um.xm: cannot modify, value is inherited
[FAIL] config-file=/projects/ukca-imp/chwel/cylc-run/u-bc542/work/20140901T0000Z/fcm_make_um/fcm-make.cfg:2
[FAIL] config-file= - file:///home/d04/fcm/srv/svn/um.xm/main/trunk/fcm-make/meto-xc40-cce/um-atmos-safe.cfg@45850:10
[FAIL] config-file= -  - file:///home/d04/fcm/srv/svn/um.xm/main/trunk/fcm-make/inc/um-atmos-common.cfg@45850:29

[FAIL] fcm make -f /projects/ukca-imp/chwel/cylc-run/u-bc542/work/20140901T0000Z/fcm_make_um/fcm-make.cfg -C /var/spool/jtmp/8793393.xcs00.Zmi09O/fcm_make_um.20140901T0000Z.u-bc542jrpzGZ -j 6 --archive # return-code=9
2018-10-30T17:42:24Z CRITICAL - failed/EXIT

It's similar to #2488 , but I'm not using a different version of the UM as they were; the run uses /home/d05/frum/cylc-run/vn10.9_prebuilds/share/fcm_make_meto_xc40_cce_um_safe_omp , as it did before.

The fix suggested in #2488 worked (to get through fcm_make_um), but then the change in date or input files makes it hit an unexpected NetCDF error in atmos.

I'm unsure if the error has to do with my files or the new extract.location problem - could it be caused by the same thing?

Cheers,
Chris

Change History (3)

comment:1 Changed 2 weeks ago by ros

Hi Chris,

In the job.out log near the bottom the error message indicates a missing file:

Error in EM_FOPEN: No such file or directory - //home/d00/chwel/emissions/cmip6/emissions/historical/control/2006-2016/NO_aircrft_anthropogenic_2006_2016_time_series.nc

????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!!       ERROR        ???!!!???!!!???!!!???!!!???!!!
?  Error code: 1
?  Error from routine: EM_FOPEN
?  Error message: NetCDF error
?  Error from processor: 0
?  Error number: 39
????????????????????????????????????????????????????????????????????????????????

Correct the pathname and try again.

Cheers,
Ros.

comment:2 Changed 2 weeks ago by ChrisWells

Hi Ros,

missed that; my bad.

Apologies,
Chris

comment:3 Changed 6 days ago by willie

  • Platform set to Monsoon2
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.