Opened 8 months ago

Closed 7 months ago

#2660 closed help (fixed)

Error compiling fcm_make_um

Reported by: scottan Owned by: um_support
Component: UM Model Keywords: UKCA
Cc: nla27@… Platform: Monsoon2
UM Version: 10.9

Description

My UM model setup on MONSOOn has suddenly stopped compiling (first noticed yesterday 30 October). Originally on suite u-bb800 #95238, same error was reproduced on suite u-az529, which was known to function correctly. I suspect something has gone wrong with my configuration on the machine, given it has been reproduced across suites.

Please let me know if you can help.

The contents of the job.err are below:

WARNING:
This computer is provided for the processing of official information.
Unauthorised access described in Met Office SyOps? may constitute a criminal offence.
All activity on the system is liable to monitoring.
[FAIL] extract.location{primary}[um] = fcm:um.xm: cannot modify, value is inherited
[FAIL] config-file=/projects/ukca-cam/sanic/cylc-run/u-bb800/work/19880901T0000Z/fcm_make_um/fcm-make.cfg:2
[FAIL] config-file= - file:///home/d04/fcm/srv/svn/um.xm/main/trunk/fcm-make/meto-xc40-cce/um-atmos-safe.cfg@45850:10
[FAIL] config-file= - - file:///home/d04/fcm/srv/svn/um.xm/main/trunk/fcm-make/inc/um-atmos-common.cfg@45850:29

[FAIL] fcm make -f /projects/ukca-cam/sanic/cylc-run/u-bb800/work/19880901T0000Z/fcm_make_um/fcm-make.cfg -C /var/spool/jtmp/8845405.xcs00.7PydxL/fcm_make_um.19880901T0000Z.u-bb800QZoS1c -j 6 —archive # return-code=9
2018-10-31T12:17:28Z CRITICAL - failed/EXIT

Kind regards,
Scott

Attachments (2)

out.log (6.0 KB) - added by scottan 8 months ago.
log file
out.err (902 bytes) - added by scottan 8 months ago.
Error file

Download all attachments as: .zip

Change History (5)

Changed 8 months ago by scottan

log file

Changed 8 months ago by scottan

Error file

comment:1 Changed 8 months ago by ros

Hi Scott,

I believe it is something to do with the PREBUILD, but I don't know what. I get this too and am aware of a couple of other people encountering this. I will contact the Met Office to see if anything has changed recently, but in the meantime a workaround of removing use of the PREBUILD should fix this.

In site/MONSooN.rc under the [[UMBUILD]] section replace

PREBUILD = {{PREBUILDS}}/fcm_make_meto_xc40_cce_um_safe_omp

with

PREBUILD =

Cheers,
Ros.

comment:2 Changed 7 months ago by scottan

Dear Ros,

Thank you, just checked it and it has compiled ok with your suggested change below.

cheers,
Scott

comment:3 Changed 7 months ago by ros

  • Resolution set to fixed
  • Status changed from new to closed

Hi Scott,

Just to update, that the problem was caused by a configuration change on Monsoon and the correct course of action is to not use prebuilds.

I shall close this ticket now.

Regards,
Ros.

Note: See TracTickets for help on using tickets.