Opened 7 months ago

Closed 7 months ago

#2678 closed help (answered)

Monsoon cannot find rose command

Reported by: jokea Owned by: um_support
Component: Rose/Cylc Keywords: Monsoon, rose, postproc
Cc: Platform: Monsoon2
UM Version: 11.1

Description

Hi,

I've been running the rose suite u-bc310 for a while now with no problems, but last week it spontaneously seemed to stop working. When I run

rose suite-run or rose suite-run --new

the terminal errors out before cylc can be invoked with:

[INFO] symlink: /projects/codyphy/jokea/cylc-run/u-bc310/share <= share
[INFO] delete: work/
[INFO] symlink: /projects/codyphy/jokea/cylc-run/u-bc310/work <= work
[FAIL] ssh -oBatchMode=yes -oStrictHostKeyChecking=no -n postproc env\ ROSE_VERSION=2018.06.0\ CYLC_VERSION=7.7.2\ bash\ -l\ -c\ \'\"$0\"\ \"$@\"\'\ rose\ suite-run\ -vv\ -n\ u-bc310\ --run=run\ --remote=uuid=b0c01737-731b-4f1c-b273-7fe780b504b6,now-str=20181119T095443Z # return-code=127, stderr=
[FAIL] WARNING:
[FAIL] This computer is provided for the processing of official information.
[FAIL] Unauthorised access described in Met Office SyOps may constitute a criminal offence.
[FAIL] All activity on the system is liable to monitoring.
[FAIL] rose: rose: command not found

This seems to be a broader issue as none of my suites are working now.

The docs suggest that this can happen if your .bash_profile and .bashrc aren't set up correctly, but I haven't changed anything in these files and so lines like PATH=$PATH:~fcm/bin are all still present. I waited a week in case Monsoon itself was having issues, but the problem is persisting. The error seems to relate to ssh-ing into postproc, but I'm able to log on to postproc just fine outside of the suite.

Any ideas?

Change History (4)

comment:1 Changed 7 months ago by willie

Hi,

The Monsoon post processor was down last week and also this morning - see the Monsoon collaboration service external group on Yammer https://www.yammer.com/reading.ac.uk/#/threads/show?threadId=1194556205.

Willie

comment:2 Changed 7 months ago by willie

Hi,

A better link is https://collab.metoffice.gov.uk/twiki/bin/view/Support/MONSooN and click on the Latest news on Yammer link. You still need to sign up to Yammer though.

Willie

comment:3 Changed 7 months ago by jokea

Willie,

That's fine, I'll just wait a little longer then. I've been struggling to get on that yammer group for ages, but my exeter.ac.uk email always denies me access to join and redirects me away. I'll have another go at finding a way to get on it when I get a chance.

Thanks,
John

comment:4 Changed 7 months ago by jokea

  • Resolution set to answered
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.