Opened 10 months ago

Closed 9 months ago

Last modified 9 months ago

#2693 closed help (fixed)

svn issue when using rosie on jasmin

Reported by: csteadman Owned by: ros
Component: MOSRS Keywords:
Cc: Platform: JASMIN
UM Version:

Description

Hi,

I'm having an issue when using rosie on JASMIN. I can launch rosie, but when I try to checkout a suite, I get the following error:

rose.popen.RosePopenError?: svn cat https://code.metoffice.gov.uk/svn/roses-u/a/x/6/0/8/trunk/rose-suite.info@93041 # return-code=1, stderr=
svn: E215004: Authentication failed and interactive prompting is disabled; see the —force-interactive option
svn: E215004: Unable to connect to a repository at URL 'https://code.metoffice.gov.uk/svn/roses-u/a/x/6/0/8/trunk/rose-suite.info'
svn: E215004: No more credentials or we tried too many times.
Authentication failed

I have tried configuring the ~/.subversion/servers file using the instructions at
https://code.metoffice.gov.uk/trac/home/wiki/FAQ#ConfiguringSubversionaccess

My MOSRS password is cached properly.

I also followed the instructions for ~/.metomi/rose.conf at https://jules-lsm.github.io/tutorial/bg_info/tutorial_julesrose/jr_jasmin_setup.html, and this is the result from rose config:

[csteadman@jasmin-sci2 ~]$ rose config
[rose-stem]
automatic-options=SITE=jasmin

[rose-suite-run]
#hosts=jasmin-cylc.ceda.ac.uk
root-dir-share=*=/work/scratch/$USER
root-dir-work=*=/work/scratch/$USER

[rosie-id]
prefix-default=u
prefix-location.u=https://code.metoffice.gov.uk/svn/roses-u
prefix-username.u=claudiasteadman
#username is all in lower case
prefix-ws.u=https://code.metoffice.gov.uk/rosie/u
[2]+ Done rosie go

Could you please let me know what I should try next?

Cheers,
Claudia

Change History (3)

comment:1 Changed 9 months ago by ros

  • Component changed from UM Model to MOSRS
  • Owner changed from um_support to ros
  • Platform set to JASMIN
  • Status changed from new to accepted

Hi Claudia,

Sorry for the delay. Can you give me permission to see you files on JASMIN please? Specifically I need to be able to see your ~/.subversion and ~/.metomi directories. The error message you are getting indicates that your MOSRS password is not cached properly.

Can you please run fcm ls fcm:um.x-tr?
This should list the MOSRS UM repository and will not prompt for password if it is cached ok.

Regards,
Ros

comment:2 Changed 9 months ago by csteadman

  • Resolution set to fixed
  • Status changed from accepted to closed

Hi Ros,

Thanks for your reply. Dave (I'm not sure which one) from the Met Office helped me out, and I can now check out jobs using rosie on both Jasmin and Monsoon.

On Jasmin, I needed to source mosrs-setup-gpg-agent in the current shell by running “. mosrs-setup-gpg-agent” (I hadn't included the dot+space before the command.)

On Monsoon, I was following out of date instructions at
https://collab.metoffice.gov.uk/twiki/bin/view/Support/MONSooNRose. Dave pointed me to the latest instructions at
https://code.metoffice.gov.uk/trac/home/wiki/AuthenticationCaching#Monsoon.

Cheers,
Claudia

comment:3 Changed 9 months ago by ros

Hi Claudia,

Thanks for letting us know.

For others who may read this the MONSooNRose page you have pointed to above has since been updated.
I will close this query now.

Thanks.
Cheers,
Ros.

Note: See TracTickets for help on using tickets.