Opened 5 months ago

Closed 5 months ago

#2710 closed help (fixed)

Setting up CMIP6/PMIP4 mid-Holocene simulation using UKESM1

Reported by: charlie Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version:

Description

Hi,

Right then… Having completed the CMIP6/PMIP4 mid-Holocene simulation using GC 3.1, I now want to repeat this using UKESM1. I have obtained UKESM1 preindustrial control suite (having contacted the owner determine the correct revision) and will begin modifying it to make it mid-Holocene - I can do this myself, assuming it's a similar process to GC 3.1.

My suite is u-be251.

However, before I start fiddling with the science, there are 2 things which need changing:

1) The suite is currently setup to run on Monsoon (or possibly the internal MO machine, I'm not sure), so needs to be ported as I have resources on Archer
2) The postprocessing needs to be changed, either to the RDF or directly to JASMIN

Please would you be able to help with these 2 steps?

Before that, however, I believe some of the meta data might be missing, because when I go to the UM app within the GUI I get "Could not find meta data for/data/users/moci/metadata/UKESM/um-atmos/HEAD". Moreover, none of the usual UM options are available, presumably because of this error?

Please can you help?

Charlie

Change History (9)

comment:1 Changed 5 months ago by dcase

Charlie,

if you're looking for a suite which will run the UKESM and transfer the data to JASMIN, I'm currently working on suite u-bd998, which is the beta preindustrial control. It will need a little tidying (I think that there are a couple of hard-coded references to me in there), but it should run a couple of months of simulation and archive them as a start.

If I've understood you correctly, this should help with the points that you refer to.

Dave

comment:2 Changed 5 months ago by charlie

Hi Dave,

Thanks. However, the problem is: how does your beta version differ from the actual kosher CMIP6 preindustrial control which has already been run? CMIP6 protocol states that the mid-Holocene simulation must be scientifically identical to the PI control, other than certain modifications to make it mid-Holocene. So I need to start with the actual PI control that has been run for CMIP6.

Charlie

comment:3 Changed 5 months ago by dcase

Charlie,

you have a suite with the correct science settings, no? The one that I suggested looking at should help you with ARCHER issues and data transfer. I guess if there are discrepancies for the inter-comparison protocol you should go with what the owner of the correct suite has suggested.

Dave

comment:4 Changed 5 months ago by charlie

Oh, I see, sorry. I thought you meant to actually copy your suite, but I think you mean stick with my existing suite and just change the relevant bits according to what your suite says?

comment:5 Changed 5 months ago by dcase

I think that you could copy bd998, but if scientific parameters differ, go with what the original suite owner has said.
If you did it the other way around, it may involve copying and pasting extra files/apps and so on, which would presumably get you to the same place, but may be more effort.

There is a caveat, though, in that my suite is a work in progress, so you'll have to tinker with a couple of things (but I hope they'll be obvious).

comment:6 Changed 5 months ago by dcase

Charlie,

I was just wondering whether you ended up using this suite?
Either way, I'm assuming I can close the ticket???

Dave

comment:7 Changed 5 months ago by grenville

Charlie

you need to add the ukca_em_dir variable to the suite and leave it empty. Rose has tried to look for unsethome/d05/cwilliams/ga71/ancils/aerosols/BC_biofuel_1850_time_slice.nc.

It might have been simpler to set ukca_em_dir as /home/d05/cwilliams/ga71/ancils/aerosols, and entered the files in ukca_em_files.

Grenville

comment:8 Changed 5 months ago by charlie

Hi Grenville,

I think our tickets may have got confused, because I think your reply above is actually responding to my question in ticket #2703. This ticket is a separate issue, and can actually be closed now. I will reply to your comment in ticket #2703.

Dave: no, I didn't end up using your suite in the end because I was told that a portable version of the UKESM1 preindustrial control would be available in the next few weeks. So it makes sense to wait for that. So yes, I will close this ticket.

Charlie

comment:9 Changed 5 months ago by charlie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.