Opened 5 months ago

Closed 4 months ago

#2714 closed help (answered)

WGDOS Packing error

Reported by: amenon Owned by: um_support
Component: UM Model Keywords: WGDOS packing
Cc: Platform: ARCHER
UM Version: 10.9

Description

Dear CMS,

My 1.5 km nesting suite (u-be022 in Archer) is encountering a packing error at the LAM forecast step during the first cycle. It is failing to pack stash 1208 (which is under the output stream pp0). I tried rerunning the job by setting packing to 'unpacked', but it still gives the same packing error. I also tried setting the packing to 'Convective scale (<5 km)', that too doesn't help me to get past this error. Any suggestions? Many thanks. Here is the error message:

?  Error code: 2
?  Error from routine: WGDOS Packing (f_shum_wgdos_pack)
?  Error message: Problem packing field...
?        STASH:  1208
?        Accuracy: -6
?        Minimum:   -0.3824100705E+00
?        Maximum:    0.4434676912E+14
?        Message:  Unable to WGDOS pack to this accuracy
?  Error from processor: 252
?  Error number: 49

Arathy

Attachments (1)

packing.png (116.1 KB) - added by amenon 4 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 4 months ago by grenville

Hi Arathy

I have been looking at this error in regard to ticket 2668 - I'd like simply to switch of packing foe this stash item but have yet to find where to do that given the obscure way the nesting suite does its stash. Maybe you know how that works?

Grenville

Changed 4 months ago by amenon

comment:2 Changed 4 months ago by amenon

Hi Grenville,

I switch off the packing through the GUI at the 'Model Output Streams' as shown in the attached screenshot above. In this suite, the packing error occurs for stash 1208, that comes under the stream pp0. But I am getting the packing error even after switching off the packing for that stream. But, this method worked earlier for a 4-km suite, when I encountered similar packing error for another stash.

Arathy

comment:3 Changed 4 months ago by grenville

The suite uses "verstash" - verstash sets its own properties which override what you see in the Rose gui. I hacked the suite to not use this, but I don't know if it's needed for you work?

You can see the changes I made in /home/grenville/roses/u-bd731/suite-setup.rc and suite-macros.rc.

My suite ran for 4 hrs (it exceeded its wallclock time).

If you do this, you should be able to make changes through the Rose gui. This doesn't explain why STASH 1208 won't pack - I suspect it's being output at an invalid time.

Grenville

comment:4 Changed 4 months ago by grenville

This suite produces hrly mean radiation output with odd timestamps for diagnostics which are only available on radiation time steps - this happens because the meaning period is not a multiple of the radiation time step. The model is running OK - do you even need all the radiation diagnostics?

comment:5 Changed 4 months ago by amenon

Hi Grenville,

Thanks a lot. I was totally stuck with this error.

I turned off the verstash as I don't need them and then ran the suite and ended up again with the packing problem.

I will discuss with Andy and will turn off the radiation diagnostics if not needed. Else I will also try with changing the radiation time steps or the meaning period.

Arathy

comment:6 Changed 4 months ago by grenville

Arathy

As I mentioned earlier, I had to change /home/grenville/roses/u-bd731/suite-setup.rc and suite-macros.rc to switch off verstash - the switch in the gui didn't seem to work.

Grenville

comment:7 Changed 4 months ago by amenon

Hi Grenville,

I tried changing the suite-setup.rc file and continued with the suite. Now I got past the packing error. But the suite keeps failing at the LAM forecast as it exceeds the wallclock limit. I tried increasing the PEs and also increasing the wall clock time by up to 6 hours, still can't meet the wall clock limit. Do you have a rough idea how much should I increase the wall time or the no. of PEs to for this 1.5 km suite. The suite I am running at the moment is u-be498 in Archer.

Arathy

comment:8 Changed 4 months ago by grenville

  • Resolution set to answered
  • Status changed from new to closed

Arathy

Sounds like your 1.5km model is running - we'll close this now.

Grenville

Note: See TracTickets for help on using tickets.