Opened 9 months ago

Closed 9 months ago

#2718 closed help (fixed)

postproc process failed: TSSC_CONFLICT_WITH_EARLIER_COMMAND

Reported by: marcus Owned by: um_support
Component: UM Model Keywords: Postproc, moo commands
Cc: Platform: NEXCS
UM Version: 10.6

Description

Hi,

I get an error message during postproc in suite u-bc276. There appears to be a conflict between different moo commands. I am not sure what to do with the command IDs and therefore don't know how to debug this further. Could you please give me some advice how to resolve this?

Many thanks,
Marcus

[WARN] file:atmospp.nl: skip missing optional source: namelist:archer_arch
[WARN] file:nemocicepp.nl: skip missing optional source: namelist:archer_arch
[WARN] file:pptransfer.nl: skip missing optional source: namelist:archer_arch
[WARN] file:pptransfer.nl: skip missing optional source: namelist:pptransfer
[WARN]  Mule Module is not available. um-pumf will be used.
[WARN]  Iris Module is not available
[WARN]  [SUBPROCESS]: Command: moo put -f -vv /home/d03/makoe/cylc-run/u-bc276/share/data/History_Data/bc276a.ph20170929.pp moose:crum/u-bc276/aph.pp
[SUBPROCESS]: Error = 2:
	put command-id=658778585 failed: (SSC_TASK_REJECTION) one or more tasks are rejected.
  /home/d03/makoe/cylc-run/u-bc276/share/data/History_Data/bc276a.ph20170929.pp -> moose:/crum/u-bc276/aph.pp/bc276a.ph20170929.pp: (TSSC_CONFLICT_WITH_EARLIER_COMMAND) command conflicts with another command.
  Conflicting command-ids: 658076341, 
put: failed (2)

[WARN]  moo.py: Moose Error: user-error (see Moose docs). (ReturnCode=2) File: /home/d03/makoe/cylc-run/u-bc276/share/data/History_Data/bc276a.ph20170929.pp
[FAIL]  main_pp.py - PostProc complete. Exiting with errors in atmos_archive
[FAIL] Terminating PostProc...
[FAIL] main_pp.py atmos # return-code=1
2019-01-07T14:15:45Z CRITICAL - failed/EXIT

Change History (3)

comment:1 Changed 9 months ago by grenville

Hi Marcus

Have you tried retriggering - does ticket #2356 help?

Grenville

comment:2 Changed 9 months ago by marcus

Hi Grenville,

Re-triggering alone did not help. But ticket #2356 helped, thank you!

What worked for me was, after logging into postproc
moo kill 658076341 (which was the conflicting command ID)

Afterwards I re-triggered the failed postproc process in gcylc.

All fine now, thank you.

Happy New Year,
Marcus

comment:3 Changed 9 months ago by grenville

  • Resolution set to fixed
  • Status changed from new to closed

Glad that worked

Note: See TracTickets for help on using tickets.