#2732 closed help (fixed)

Suite which worked but now doesn't

Reported by: charlie Owned by: ros
Component: UM Model Keywords:
Cc: Platform: NEXCS
UM Version: 10.7

Description

Hi,

This ticket is closely related to my other currently active ticket (#2703), but it is a slightly separate issue so I thought it would be better to raise a separate ticket.

As I said in my previous ticket (specifically comments 16-19), before Christmas my suite u-bc205 was working. Whilst trying to get my other suite (u-be195) working, I thought it would be a good idea to try to get my suite that DOES work (u-bc205), running but with my freshly modified ancillaries. I loaded them all in (via a new ancillary versions file) and it crashed straightaway, or rather about a minute into the coupled stage. So this morning I have had a laborious task of cutting back the changes I made, to get back to it working. I have now reverted back to how it was a couple of weeks ago, and it STILL isn't working, giving the error below:

[FAIL] run_model # return-code=127

It has given me the same error this morning at every iteration, i.e. whenever I changed one ancillary back to my original.

The only thing which is now different (i.e. from this morning and when it worked before Christmas) is the postprocessing app has been upgraded to version 2.2 and the postprocessing/archiving has been changed so that it goes directly to JASMIN. That wouldn't have made a big difference, would it? Other than this, nothing is different to when it worked.

Please please can you help with this as a matter of urgency, because I desperately need to get at least one of these suites working, and as of right now this one appears to be easier to solve (because it worked once) than the other.

Charlie

Change History (5)

comment:1 Changed 11 months ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Charlie,

If you look at the line above the error message you posted it says:

/usr/bin/env: python2.7: No such file or directory

Have you fiddled with your login environment recently (.profile, .bash_profile for example) - specifically anything to do with your python setup?

Cheers,
Ros.

comment:2 Changed 11 months ago by charlie

Hell - yes I have, simply because I was told to by Monsoon - as I'm sure you know, they are shutting down exvmsrose on 12 February and say that everything now work on xcslc0 or 1. This, however, is not entirely true! I had to ask them about my MOSRS password (which is always requested by exvmsrose, but not xcslc0). They told me to follow instructions at: https://code.metoffice.gov.uk/trac/home/wiki/AuthenticationCaching#Monsoon which I did - most of this I already had, except the

[[ $- != *i* ]] && return # Stop here if not running interactively
[[ $HOSTNAME = "exvmsrose.monsoon-metoffice.co.uk" || $HOSTNAME = xcslc* ]] && . ~fcm/bin/mosrs-setup-gpg-agent

# Enable bash completion for Rose commands
[[ -f ~fcm/rose/etc/rose-bash-completion ]] && . ~fcm/rose/etc/rose-bash-completion

which I added into my .bashrc file.

This solved the first problem i.e. it now asks for my password, but then generated another problem: whenever opening rosie go or rose edit, it wouldn't open with

""ImportError?: No module named pygtk""

According to the wiki (https://collab.metoffice.gov.uk/twiki/bin/view/Support/RetirementOfRoseCylcVMs), the way to get round this is to use module load python before using either of these. Which I did, which works - or at least they appear. I put this into my .bash_profile so I wouldn't have to type this each time, so is this the problem?

Either way, this "simple change over" is not as simple as they imply. Even with the above changes, I still can't even submit any suites on xcslc0, getting another python error, so I have been sticking with exvmsrose for now.

Can you help me sort this mess out?

Charlie

comment:3 Changed 11 months ago by ros

Hi Charlie,

Yes, everything Rose/Cylc does indeed work now on xcslc0/1 but you do have to do a few things first as per the advertisement. :-)

The module unload python is required for the Rose GUIs to work but only prior to 12th February when a change/upgrade to Rose will fix this. Yes if you put it in any of your profiles it will likely cause a problem depending on how you do it and what you are running on Monsoon/NEXCS, which is why the instructions don't suggest it. It is possible to add it but only if protected appropriately. If you place that line in your ~/.bashrc file at the very end after the MOSRS setup stuff you should be ok as anything after the "#Stop here if not running interactively" won't be run except when you login interactively.

Give that a try.
I will probably add a warning to the collab page incase anybody else tries to do this.

Cheers,
Ros.

comment:4 Changed 11 months ago by charlie

Many thanks, that appears to be working.

Charlie

comment:5 Changed 11 months ago by charlie

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.