Opened 9 months ago

Closed 9 months ago

#2741 closed help (fixed)

u-bc158 Getting Segmentation Fault (address not mapped to object) error

Reported by: cwc46 Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 11.0

Description

Hi there,

My suite u-bc158 is failing at atmos-main, and I do not get a clear error message saying where things are failing, but I get a ton of 'exceptions' messages.

The first exceptions' message I got was this:

[333] exceptions: An exception was raised:11 (Segmentation fault)
[333] exceptions: the exception reports the extra information: Address not mapped to object.
[333] exceptions: whilst in a serial region
[333] exceptions: Task had pid=43933 on host nid02291
[333] exceptions: Program is "/work/n02/n02/glenchua/cylc-run/u-bc158/share/fcm_make_um/build-atmos/bin/um-atmos.exe"
[333] exceptions: calling registered handler @ 0x00417c80
Warning in umPrintMgr: umPrintExceptionHandler : Handler Invoked
[333] exceptions: Done callbacks
[333] exceptions: * GLIBC *
[333] exceptions: Data address (si_addr): 0x00000000; rip: 0x0318366d

u-bc158 is running vn11.0 and I have tried to add a non-interactive CH4 tracer (named CH4B) with prescribed emissions field.

on ARCHER the path to the log file containing the error message is
/work/n02/n02/glenchua/cylc-run/u-bc158/log/job/19880901T0000Z/atmos_main/NN/job.err

Thank you!

Change History (3)

comment:1 Changed 9 months ago by cwc46

Hi there,

Just tried to change my u-bc158/site/archer.rc file as per the suggestion in ticket #2251.

I had already

module load cray-netcdf/4.3.2
module load cray-hdf5/1.18.13

and I added the extra line

module load cdt/15.11

but it failed at the compiling stage fcm-make2-um.

Thank you!

comment:2 Changed 9 months ago by cwc46

Hi,

I managed to find and fix the problem, thanks!

comment:3 Changed 9 months ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.