Opened 5 months ago

Closed 4 months ago

#2755 closed help (fixed)

How to find fcm conflicts

Reported by: m.couldrey Owned by: ros
Component: FCM Keywords: fcm, HadGEM3
Cc: Platform: NEXCS
UM Version: 10.7

Description

Hi CMS,

I am trying to merge some of my local changes into my build of NEMO (within HadGEM3). I have checked out a version of the NEMO code (home/d00/macou/branches/NEMO_trunk) and am trying to make edits in branches/NEMO_trunk/NEMOGCM/NEMO/OPA_SRC/SBC/sbccpl.F90 but my suite fails to compile, giving the following conflict.

[FAIL] nemo/NEMOGCM/NEMO/OPA_SRC/SBC/sbccpl.F90: merge results in conflict
[FAIL] merge output: /home/d00/macou/cylc-run/u-az004/share/fcm_make_ocean/.fcm-make/extract/merge/nemo/NEMOGCM/NEMO/OPA_SRC/SBC/sbccpl.F90.diff
[FAIL] source from location 0: svn://puma.nerc.ac.uk/nemo.xm_svn/trunk/NEMOGCM/NEMO/OPA_SRC/SBC/sbccpl.F90@5518
[FAIL] source from location 1: svn://puma.nerc.ac.uk/nemo.xm_svn/branches/UKMO/dev_r5518_GO6_package/NEMOGCM/NEMO/OPA_SRC/SBC/sbccpl.F90@8638
[FAIL] !!! source from location 2: /home/d00/macou/branches/NEMO_trunk/NEMOGCM/NEMO/OPA_SRC/SBC/sbccpl.F90

[FAIL] fcm make -f /projects/nexcs-n02/macou/cylc-run/u-az004/work/18500101T0000Z/fcm_make_ocean/fcm-make.cfg -C /home/d00/macou/cylc-run/u-az004/share/fcm_make_ocean -j 4 mirror.target=xcs-c:cylc-run/u-az004/share/fcm_make_ocean mirror.prop{config-file.name}=2 # return-code=2
2019-02-04T09:25:53Z CRITICAL - failed/EXIT

I'm not quite sure how to merge the conflict, but it looks similar to the problem in the UM Training Course practical session. If I understand correctly, fcm is telling my that my version of sbccpl.F90 and that of another branch (whose?) differ from the version in the trunk. If I navigate to where my branch is (/home/d00/macou/branches) and try to merge the version from location 1 (like in the tutorial) with
fcm merge fcm:nemo.x-br/UKMO/dev_r5518_GO6_package
my terminal fills up with lots of files added since I checked out the code. The last ones being
A NEMO_trunk/NEMOGCM/fcm-make/inc/keys-orca2_sas_lim.cfg
A NEMO_trunk/NEMOGCM/fcm-make/pwr7-xlf-meto.cfg

After I hit "y" to continue the merge, a connection is attempted and I'm asked for a password

The authenticity of host 'forge.ipsl.jussieu.fr (134.157.176.26)' can't be established.
RSA key fingerprint is e2:2a:5c:a4:49:09:c4:65:8f:84:86:1c:51:80:42:97.
Are you sure you want to continue connecting (yes/no)? yes
Password:
Neither my puma nor mosrs passwords works here, but I guess this connection isn't to those machines.

If I run fcm status from my working directory (/home/d00/macou/branches) no conflicts are flagged. And if I run fcm conflicts I get nothing returned.

I'm not sure quite how to tackle this conflict because I suppose I'm not using fcm correctly. Could you please help point me the right way?

Thanks!
Matt

Change History (11)

comment:1 Changed 5 months ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

comment:2 Changed 5 months ago by ros

Hi Matt,

I can't tell exactly what's gone wrong here, but usually when the merge adds in every file from the branch being merged in it means that there is a mismatch between directory levels in the working copy and merged in copy. Doing an fcm info in your working copy shows a dodgey repository URL with an extraneous NEMO_trunk in it which will likely cause problems. I think you will need to delete your working copy and start again. Was it just sbccpl.F90 you edited? You could see if it still has your changes in and is salvageable.

I'm guessing by the repository url resolving to puma.nerc.ac.uk that you are still working on exvmsrose? If so I would strongly suggest moving to using the xcs login nodes as exvmsrose will be disappearing next week. You should hopefully have seen the link sent around with instructions. If not let me know and I'll dig them out.

Then in theory all you should then need to do is:

fcm co fcm:nemo.xm-br/UKMO/dev_r5518_GO6_package_MEDUSA_extra_CMIP6_diags <working_copy_name>

I would then try and merge in the other branch before you make you code changes.

cd <working_copy_name>
fcm merge fcm:nemo.x-br/UKMO/dev_r5518_GO6_package

I presume you do not have write access to the NEMO repository at IPSL so that you can create your own branch and save changes?

Try that and see if that gets you any further. Not sure about the connection to IPSL - I'll need to look at that further. The NEMO repository does have some oddities in the way it's setup.

Cheers,
Ros.

comment:3 Changed 5 months ago by m.couldrey

Hi Ros

Thanks for helping look into this. Yes, I probably didn't set up my branch correctly in the first place. I have notes of the changes that I've made so I'm ok to clear out my branch and start over.

I'm struggling to delete my branch. If I try fcm branch-delete in our outside of my branches/ folder, I get the error:
[FAIL] svn://puma.nerc.ac.uk/nemo.xm_svn/branches/UKMO/dev_r5518_GO6_package_MEDUSA_extra_CMIP6_diags@10628: not a valid URL of a standard FCM branch.

What am I doing wrong with the deletion?

Cheers
Matt

comment:4 Changed 5 months ago by ros

Hi Matt,

Your working copy is just a copy of an existing branch (owned by someone else) which you can't delete from the repository (also note any fcm keyword with the .xm extension e.g. nemo.xm is read-only too). So you just need to do rm ~macou/branches/NEMO_trunk to delete the working copy.

If you are going to be doing a lot of changes to the NEMO code I would suggest applying for write access to the Paris repository. I think there are guidelines for requesting this on the NEMO website.

Cheers,
Ros.

comment:5 Changed 5 months ago by ros

Sorry that should have been:

rm -r ~macou/branches/NEMO_trunk

comment:6 Changed 5 months ago by ros

P.S.
You need to delete your ~macou/branches too as I've just noticed that this directory itself is a subversion branch. Do a fcm status in there and you'll see what I mean!!! This will definitely have caused you problems.

comment:7 Changed 5 months ago by m.couldrey

Hi Ros

Thanks! I can see why I was getting stuck here! As you can tell, I wasn't quite sure how to work the fcm system! I understand what you've explained about why fcm branch-delete won't work, and I definitely don't want to do that. I'm starting fresh again (I see that my previous attempt to do so just created the nested nightmare that you've unravelled!) I won't need access to the IPSL system, the work I'm doing won't feed back to them.

Also, I'm now using xcs-c after logging into the lander as well. I hadn't seen this email you've mentioned and can't seem to find it in my inbox. I also note that the email updates to this ticket were going straight into my junk folder (which they never did before, not sure why the spam filter has started doing that…) so maybe it didn't arrive as expected.

Thanks for your help!
Matt

comment:8 Changed 5 months ago by ros

Hi Matt,

If you need the Rose/Cylc on xcs-c information it's available here:
https://collab.metoffice.gov.uk/twiki/bin/view/Support/RetirementOfRoseCylcVMs

The original announcement was probably on Yammer in the Monsoon collaboration channel.

Updated information on MOSRS password caching if you need it:
https://code.metoffice.gov.uk/trac/home/wiki/AuthenticationCaching#Monsoon

Cheers,
Ros.

comment:9 Changed 4 months ago by m.couldrey

Thanks for your help with all this Ros! I've got it together now, as well as the password caching.

One final thing that maybe you can point me in the direction, if possible please: I've been trying to access the yammer post you mentioned:
https://www.yammer.com/metoffice.gov.uk/threads/1219804877
but when I try to sign into it I get an error that my "account needs to be added as an external user in the tenant first". Is there a how-to guide to get access to the MO Yammer? I can't seem to find one.

Thanks!
Matt

comment:10 Changed 4 months ago by ros

Glad you've managed to sort things out.

Re the Yammer: Sounds like you either haven't been invited to the Yammer group or the invite wasn't activated. Doesn't matter which; I will ask the Met Office to send you a new invite.

Cheers,
Ros.

comment:11 Changed 4 months ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.