Opened 8 months ago

Closed 8 months ago

#2770 closed help (fixed)

Transferring data from Monsoon to JASMIN

Reported by: carlocafaro Owned by: um_support
Component: Data Keywords: Data Transfer
Cc: Platform: Monsoon2
UM Version:

Description

Moved from email to helpdesk:

Carlo is trying to transfer data under /projects/diamet/saclar/SWIFT/ensembles/ to a GWS on JASMIN. This is about 325Gb.

He has been pointed to the file transfer link on the Collaboration Twiki:

https://collab.metoffice.gov.uk/twiki/bin/view/Support/MONSooNFAQs#File%20transfer%20to%20and%20from%20Monsoo

Recommending to use scp or rsync as the easiest to setup.

Change History (6)

comment:1 Changed 8 months ago by ros

Last email from Carlo:

Apparently not, that's what I got.

ccafaro@xcslc0:~> ssh ccafaro@jasmin-xfer1.ceda.ac.uk

            Access to this system is monitored and restricted to
            authorised users.   If you do not have authorisation
            to use  this system,  you should not  proceed beyond
            this point and should disconnect immediately.

            Unauthorised use could lead to prosecution.

    (See also - http://www.stfc.ac.uk/aup)

Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
Last edited 8 months ago by ros (previous) (diff)

comment:2 Changed 8 months ago by ros

Hi Carlo,

Do you have your jasmin private key under ~/.ssh/<id_rsa_jasmin>?

Where <id_rsa_jasmin> is what you called the key when you created it during the application process for jasmin. If you haven't done this then you need to copy your key over from whatever platform you usually log into jasmin from.

Then follow the instructions on JASMIN website explaining how to log in: https://help.jasmin.ac.uk/article/187-login

Regards,
Ros.

comment:3 Changed 8 months ago by carlocafaro

Hi,
I have copied the jasmin key to monsoon but I am still getting the same error message (permission denied) when I try to scp from monsoon to jasmin.

Best regards,
Carlo

comment:4 Changed 8 months ago by ros

Have you setup ssh-agent as per the instructions I sent above?

Regards,
Ros.

comment:5 Changed 8 months ago by carlocafaro

Hi Ros,
the problem is solved now. I had setup ssh-agent but I was still getting a warning, so I had to run chmod to change permission to the public keys.

Thanks,
Carlo

comment:6 Changed 8 months ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.