Opened 11 years ago

Closed 11 years ago

#278 closed help (fixed)

Sea Ice ancillary reconfiguration

Reported by: beh27 Owned by: jeff
Component: UM Model Keywords:
Cc: Platform:
UM Version: 6.1

Description

Hi,

I'm wanting to add some sea ice to a LAM job that I have running successfully. I'm presuming you have to add the sea ice in to the global run as well as the LAM run, but correct me if otherwise. I have the .nc files with the ice I would like to add, both for the global and LAM jobs. I've looked at xancil and have produced what appears to be sensible ancillary files for the global and LAM runs, (ie, only one time coordinate, they look fine in xconv), but now comes the difficult part: actually getting the UM to accept them. I've tried a number of times with a number of configurations, but each time the UM fails after/during reconfiguration. the .start files produced have all fields at 0. Is there anything special I need to be doing in order for the UM to accept the sea ice? I read that I might need to reconfigure the mask/orog/veg as well, but I have tried this and still doesnt work. Any ideas?

Thanks,

Benjamin

Change History (10)

comment:1 Changed 11 years ago by jeff

  • Owner changed from um_support to jeff
  • Status changed from new to accepted

Hi Benjamin

Can you give me access to the ancillary and netcdf files you have created and also the .leave file output from your UM runs.

Jeff.

comment:2 Changed 11 years ago by beh27

Sure, you should have access to the files now. They are in my work dir, the netcdf's under 'ice' and the ancillaries under 'ancil'. The experiment xean is the experiment that i extracted the ice files from ('a' being global and 'c' being LAM) The job I've been playing around with is xebca so there are a number of .leave files from various trials. Sorry I cant be more specific about what i did on each. I ended up only running the reconf stage for each trial.

I have just looked at a colleagues job (gnp, xcme) and it seems that she reconfigured only her LAM with the new ice ancil files so I'm going to give this a go now and let you know how it runs. Any advice in the mean time gratefully received…

Benjamin

comment:3 Changed 11 years ago by jeff

Hi Benjamin

Can you go to umui panel

Reconfiguration → Reconfiguration Output

and select "Extra diagnostic messages", then rerun the reconfiguration and I'll look at the output file.

Jeff.

comment:4 Changed 11 years ago by beh27

Hi Jeff,

I have done as you asked. The output file for the reconfiguration is xebca000.xebca.d09146.t170829.comp.leave and you should have permission to open it. As a background, this is a global run with only the sea ice ancillary in the reconfiguration. The more i read about this, it seems that you need more ancillary files to get the reconfiguration to work. ie orog, mask, soil etc, but I will await your advice on this…

Thanks

Benjamin

comment:5 Changed 11 years ago by beh27

Hi, here's an update:

I've run the job twice more with more ancils included (orog, mask, soil, veg etc) from the folders /work/n02/n02/hum/vn6.1/ancil/atmos/n216_432325 and /work/n02/n02/hum/vn6.1/ancil/atmos/n320 (just in case the resolution makes a difference). Have a look at the job setup in the umui if you want to see which ones i've included. Neither of these have worked, but the leave files are at xebca000.xebca.d09147.t092443.comp.leave and xebca000.xebca.d09147.t100628.comp.leave respectively if anything can be gleaned from them.

Thanks,

Benjamin

comment:6 Changed 11 years ago by beh27

Just realised I hadn't given you permission for the two .leave files above. I have now…

Benjamin

comment:7 Changed 11 years ago by jeff

Hi Benjamin

Looking at your output directory you seem to have done lot of runs so I'm not sure what the current position is with this problem. With sea ice you may need to do SST at the same time but I'm not aware of needing any other ancillary field. Some of your jobs failed because the ancillary files you requested did not exist, others I'm not sure why they failed. There is no point me looking at why some job failed if you have moved on to other jobs. Can you let me know the current state of play and what your current problem is, including the relevant output file.

Jeff.

comment:8 Changed 11 years ago by beh27

Hi Jeff,

Thanks, I will try including the sst ancillary as well. Yes, I have been running the job a number of times, sorry that this has confused things somewhat, but I was trying to self fix with various different ancils and combinations, but to no avail. I was lead to believe (from other helpdesk enquiries) that other ancils were required, but I will try using the sst ancil and see where that gets me and report back on how things go with some clearer signposting to the problems I am encountering…

Thanks,

Benjamin

comment:9 Changed 11 years ago by beh27

Hi Jeff,

I've got it working now. The problem was, as you suggested, that I wasn't including the sst ancil. Once i had created it the job ran fine. I didn't need to run a global sst/ice run to get new boundary conditions, i could use the boundary conditions from the previous no ice run.

You can close this ticket now, thanks for your help…

Benjamin

comment:10 Changed 11 years ago by jeff

  • Resolution set to fixed
  • Status changed from accepted to closed

Hi Benjamin

Glad you have got it all sorted.

Jeff.

Note: See TracTickets for help on using tickets.