Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#2786 closed help (fixed)

Switching off dynamical vegetation

Reported by: ChrisWells Owned by: um_support
Component: UKESM Keywords:
Cc: yongming.tang@… Platform:
UM Version:

Description

Hi,

I'm going to use UKESM to do emissions perturbation experiments, and, at least at first, I'd like to run the model with constant vegetation so I can investigate the impacts of my perturbations more clearly.

However, I can't see how to do this easily - JULES in the GUI doesn't seem to have a main switch. How would I go about turning dynamical vegetation off in UKESM?

Cheers,
Chris

Change History (8)

comment:1 Changed 6 months ago by grenville

  • Cc yongming.tang@… added

comment:2 Changed 6 months ago by yongming

Hi Chris,

Go to um → namelist → JULES Science Settings →JULES vegetation options, Find switch l_triffid and set this to false.

Yongming

comment:3 Changed 6 months ago by ChrisWells

  • Resolution set to fixed
  • Status changed from new to closed

Hi Yongming,

Thanks! I'll close this ticket now,
Cheers,

Chris

comment:4 follow-up: Changed 6 months ago by ChrisWells

Hi Yongming,

I changed only the setting you mentioned in my suite (u-bg379, copy of Historical UKESM) and got this error in Recon:

????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!!       ERROR        ???!!!???!!!???!!!???!!!???!!!
?  Error code: 100
?  Error from routine: check_jules_soil_biogeochem
?  Error message: RothC and ECOSSE soil models need a veg model (TRIFFID). Set l_triffid=T.
?  Error from processor: 17
?  Error number: 2
????????????????????????????????????????????????????????????????????????????????

Was there some other option I should have changed?

Cheers,
Chris

comment:5 in reply to: ↑ 4 Changed 6 months ago by yongming

Replying to ChrisWells:

Hi Yongming,

I changed only the setting you mentioned in my suite (u-bg379, copy of Historical UKESM) and got this error in Recon:

????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!!       ERROR        ???!!!???!!!???!!!???!!!???!!!
?  Error code: 100
?  Error from routine: check_jules_soil_biogeochem
?  Error message: RothC and ECOSSE soil models need a veg model (TRIFFID). Set l_triffid=T.
?  Error from processor: 17
?  Error number: 2
????????????????????????????????????????????????????????????????????????????????

Was there some other option I should have changed?

Cheers,
Chris

Hi Chris,

This suggest that you can't run RothC and ECOSSE soil models with l_triffid=F option. You need to change other science options that works with it?

From your error message, I suggest you go to um → namelist → JULES Science Settings →JULES soil biogeochem, you'll find variable soil_bgc_model and choose Single pool model instead.

Cheers

Yongming

comment:6 Changed 6 months ago by ChrisWells

Hi Yongming,

Thanks for the info, and the suggestion!

Cheers,
Chris

comment:7 follow-up: Changed 6 months ago by ChrisWells

Hi Yongming,

Sorry, I'm stuck again - the suite got past Recon, but now on Coupled it gives

???????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!!       ERROR        ???!!!???!!!???!!!???!!!???!!!
?  Error code: 67
?  Error from routine: INANCILA
?  Error message:  INANCILA: update requested for STASHcode 447
?        but prognostic address not set.
?        As prognostic is not present in UM run, please turn off ancil updating
?        via the items namelist.
?  Error from processor: 252
?  Error number: 259
????????????????????????????????????????????????????????????????????????????????

I can see there is no stash 447 in the STASH window, and that it is just before crop and pasture fraction, so presumably in the right place for JULES stuff, but I am unsure what to turn off in the namelist here - do you know what I should do?

Cheers,
Chris

comment:8 in reply to: ↑ 7 Changed 6 months ago by yongming

Replying to ChrisWells:

Hi Yongming,

Sorry, I'm stuck again - the suite got past Recon, but now on Coupled it gives

???????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!!       ERROR        ???!!!???!!!???!!!???!!!???!!!
?  Error code: 67
?  Error from routine: INANCILA
?  Error message:  INANCILA: update requested for STASHcode 447
?        but prognostic address not set.
?        As prognostic is not present in UM run, please turn off ancil updating
?        via the items namelist.
?  Error from processor: 252
?  Error number: 259
????????????????????????????????????????????????????????????????????????????????

I can see there is no stash 447 in the STASH window, and that it is just before crop and pasture fraction, so presumably in the right place for JULES stuff, but I am unsure what to turn off in the namelist here - do you know what I should do?

Cheers,
Chris

Hi Chris,

go to um → namelist → Configure ancils …., and you should find the item with stashcode 447, click on this item to view and edit it — switch the update_ancil to false.

You might need to do similar things to other items.

I am closing this ticket now.

Good luck

Yongming

Note: See TracTickets for help on using tickets.