Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#2790 closed help (fixed)

failure in fcm_make_um

Reported by: ggxmy Owned by: um_support
Component: UKCA Keywords:
Cc: Platform: Monsoon2
UM Version: 11.0

Description

This may be another basic problem. Now I submitted the job u-bg140 but fcm_make_um failed with job.err like this;

/home/d03/myosh/.bash_profile: line 14: /home/d03/myosh/.ssh/ssh-setup: No such file or directory
/home/d03/myosh/.bash_profile: line 14: /home/d03/myosh/.ssh/ssh-setup: No such file or directory
[FAIL] ukca_vapour.o: bad or missing dependency (type=o)
[FAIL]     required by: ukca_conden_mod.o
[FAIL]     required by: UKCA_CONDEN_MOD.mod
[FAIL]     required by: ukca_aero_step_mod.o
[FAIL]     required by: UKCA_AERO_STEP_MOD.mod
[FAIL]     required by: ukca_aero_ctl_mod.o
[FAIL]     required by: UKCA_AERO_CTL_MOD.mod
[FAIL]     required by: ukca_main1_mod.o
[FAIL]     required by: UKCA_MAIN1_MOD.mod
[FAIL]     required by: atm_step_4a.o
[FAIL]     required by: u_model_4a.o
[FAIL]     required by: um_shell.o
[FAIL]     required by: um-atmos.exe

[FAIL] fcm make -f /working/d03/myosh/cylc-run/u-bg140/work/19970901T0000Z/fcm_make_um/fcm-make.cfg -C /var/spool/jtmp/9330952.xcs00.D_Ney2/fcm_make_um.19970901T0000Z.u-bg140PzVvyu -j 6 --archive # return-code=2
2019-02-26T15:24:08Z CRITICAL - failed/EXIT

This job is created by copying my running job u-bd857 and adding a branch;

branches/dev/masaruyoshioka/vn11.0_updateGLOMAPtoDhomse14ACP@66168

So I guess the failure should be related to this branch. Please could you help me with this?

Thanks,
Masaru

Change History (6)

comment:1 Changed 9 months ago by grenville

Masaru

in ukca_conden.F90 add

USE ukca_vapour_mod, ONLY: ukca_vapour

Grenville

comment:2 Changed 9 months ago by ggxmy

Thank you, Grenville. Is that what this message says? Isn't there more detailed output like old *.leave file?

comment:3 Changed 9 months ago by ggxmy

I added that line but the run still crashes and gives me exactly the same error messages. I don't know what to do now.
"grep ukca_vapour *" returns following lines (some lines are omitted).

ukca_conden.F90:163:USE ukca_vapour_mod,      ONLY: ukca_vapour !MY ADDED (6-2)
ukca_conden.F90:297:         CALL ukca_vapour(nbox,t,pmid,s,rp,vpkel,wts,rhosol_strat)

ukca_vapour.F90:42:MODULE ukca_vapour_mod
ukca_vapour.F90:50:SUBROUTINE ukca_vapour(nbox,t,pmid,s,rp,vpkel,wts,rhosol_strat)
                                        
ukca_volume_mode.F90:176:USE ukca_vapour_mod, ONLY: ukca_vapour                          
ukca_volume_mode.F90:266:CALL ukca_vapour(nbox,t,pmid,s,rp,vpkel,wts,rhosol_strat)       

the only differences between ukca_conden.F90:163 and ukca_volume_mode.F90:176 are number of white spaces and comment at the end. So it should be OK isn't it? I committed the change (branches/dev/masaruyoshioka/vn11.0_updateGLOMAPtoDhomse14ACP@66569) and included it in the job which I committed as well (u-bg140@107905). The built code (/projects/ukca-leeds/myosh/cylc-run/u-bg140/share/fcm_make_um/preprocess-atmos/src/um/src/atmosphere/UKCA/ukca_conden.F90) does include the line 163 above.

Can you see a problem? I guess maybe I have to refresh the run somehow, perhaps by deleting some files or directories? If so please suggest me.

Thank you.
Masaru

comment:4 Changed 9 months ago by grenville

Masaru

Have you attended a UM Training course for Rose/Cylc??

Try rose suite-run —new from the suite directory.

Grenville

comment:5 Changed 9 months ago by ggxmy

  • Resolution set to fixed
  • Status changed from new to closed

HI Grenville,

NO. I applied for UM and UKCA training courses and my application for the former was declined, I think.

Anyway I deleted "!DEPENDS ON ukca_vapour" line, which was a bit suspicious, and tried "rose suite-run —new". I'm not sure which one or both worked but now I get a different error. So I guess the run has gone through this step now. Thank you.

Masaru

comment:6 Changed 9 months ago by grenville

Masaru

We are running training in April - I can highly recommend it, see https://www.ncas.ac.uk/en/introduction-to-unified-model-course

Grenville

Note: See TracTickets for help on using tickets.