Opened 8 months ago

Closed 8 months ago

#2792 closed help (fixed)

FCM now

Reported by: ggxmy Owned by: um_support
Component: FCM Keywords:
Cc: Platform: Monsoon2
UM Version: 11.0

Description

Now that exvmsrose is retiring, which computer should I be logged in to do FCM tasks? I just tried from xcslc0 and 1 but it didn't seem to work. I got messages like these;

myosh@xcslc0:vn11.0_updateGLOMAPtoDhomse14ACP $ fcm commit
[FAIL] svn status --ignore-externals --show-updates # rc=1
[FAIL] svn: E215004: Authentication failed and interactive prompting is disabled; see the --force-interactive option
[FAIL] svn: E215004: Unable to connect to a repository at URL 'https://code.metoffice.gov.uk/svn/um/main/branches/dev/masaruyoshioka/vn11.0_updateGLOMAPtoDhomse14ACP'
[FAIL] svn: E215004: No more credentials or we tried too many times.
[FAIL] Authentication failed

Unlike exvmsrose, when I login to xcslc0 (or 1) I am not asked MOSRS password, and I thought that might be the problem. But xcslc0 (or 1) does not seem to accept "mosrs-cache-password" command;

myosh@xcslc0:vn11.0_updateGLOMAPtoDhomse14ACP $ mosrs-cache-password
gpg-agent: no process found
Error: gpg-agent not working
Run "mosrs-cache-password" to try caching your password again

What should I do? Could you please help me?

Thanks,
Masaru

Change History (5)

comment:1 Changed 8 months ago by ros

Hi Masaru,

Did you follow the instructions in the link I sent you in ticket #2789?

Regards,
Ros.

comment:2 Changed 8 months ago by ggxmy

I thought I did… although I might have missed something. It doesn't say anything about FCM, does it?

comment:3 Changed 8 months ago by ros

Yes it tells you what changes you need to make to set up caching of your MOSRS password on xcslc0/xcslc1.

comment:4 Changed 8 months ago by ggxmy

You must mean to follow this then.
https://code.metoffice.gov.uk/trac/home/wiki/AuthenticationCaching#Monsoon

OK it worked. Thank you.

comment:5 Changed 8 months ago by ggxmy

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.