Opened 5 months ago

Closed 5 months ago

#2815 closed help (fixed)

Build error running UM8.5

Reported by: zliu Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: ARCHER
UM Version: 8.5

Description

Hi,

I get an error when running UM8.5 with umui. The error shows as follows:

cray-mpich/7.1.1
Currently Loaded Modulefiles:

1) modules/3.2.10.6
2) eswrap/1.3.3-1.020200.1280.0
3) switch/1.0-1.0502.60522.1.61.ari
4) cce/8.3.7
5) craype-network-aries
6) craype/2.5.10
7) cray-libsci/13.0.1
8) udreg/2.3.2-1.0502.10518.2.17.ari
9) ugni/6.0-1.0502.10863.8.29.ari

10) pmi/5.0.12
11) dmapp/7.0.1-1.0502.11080.8.76.ari
12) gni-headers/4.0-1.0502.10859.7.8.ari
13) xpmem/0.1-2.0502.64982.5.3.ari
14) dvs/2.5_0.9.0-1.0502.2188.1.116.ari
15) alps/5.2.4-2.0502.9774.31.11.ari
16) rca/1.0.0-2.0502.60530.1.62.ari
17) atp/2.1.0
18) PrgEnv?-cray/5.2.82
19) pbs/12.2.401.141761
20) craype-ivybridge
21) cray-mpich/7.1.1
22) packages-archer
23) bolt/0.6
24) nano/2.2.6
25) leave_time/1.3.0
26) quickstart/1.0
27) ack/2.14
28) openssl/1.1.0g_build1
29) curl/7.58.0_build1
30) git/2.16.2_build1
31) epcc-tools/8.0
32) xalt/0.6.0
33) cray-netcdf/4.3.2

cray-mpich/7.5.5(34):ERROR:150: Module 'cray-mpich/7.5.5' conflicts with the currently loaded module(s) 'cray-mpich/7.1.1'
cray-mpich/7.5.5(34):ERROR:102: Tcl command execution failed: conflict cray-mpich

FCM 2017.10.0 (/fs2/y07/y07/umshared/software/fcm-2017.10.0)
COMP_UMSCRIPTS is true - run build command
cray-mpich/7.5.5(34):ERROR:150: Module 'cray-mpich/7.5.5' conflicts with the currently loaded module(s) 'cray-mpich/7.1.1'
cray-mpich/7.5.5(34):ERROR:102: Tcl command execution failed: conflict cray-mpich

Could you please help me to solve this issue? Thanks.

Cheers,
zhen

Change History (6)

comment:1 Changed 5 months ago by ros

Hi Zhen,

This is one of those error messages that you can safely ignore and occurs in all UMUI builds - there will be another error message to indicate what has gone wrong.

If you need further help with this you will need to let us know what the job id is.

Regards,
Ros.

comment:2 Changed 5 months ago by zliu

Hi Ros,

Yes, I do need further help because the model doesn't build successfully.
The job id is xojoa.
Many thanks.

zhen

comment:3 Changed 5 months ago by zliu

Hi Ros,

If I can ignore the error, the model may build successfully. I am not sure but the model didn't produce any output. Please still help. Thanks.

zhen

comment:4 Changed 5 months ago by ros

Hi Zhen,

The model has build successfully. Search for "build is OK" and you will see that it has built the model and recon ok. Also you have executables in /work/n02/n02/zliu/umui_code/xojoa/umatmos/bin and similarly for umrecon.

See xojoa000.xojoa.d19077.t090002.rcf.leave for the error which occurred when running the reconfiguration:

OPEN:  File /work/n02/n02/zliu/INPUTFILES/initial_conditions/xnbrda.da20130101_00 to be Opened on Unit 10 does not Exist
OPEN:  **WARNING: FILE NOT FOUND

Regards,
Ros.

comment:5 Changed 5 months ago by zliu

Hi Ros,

Thanks for your quick responses and terrific help.

Cheers,
zhen

comment:6 Changed 5 months ago by ros

  • Platform set to ARCHER
  • Resolution set to fixed
  • Status changed from new to closed
  • UM Version set to 8.5
Note: See TracTickets for help on using tickets.