Opened 6 months ago

Closed 6 months ago

#2830 closed help (fixed)

Postproc failing on MONSooN2

Reported by: scottan Owned by: ros
Component: UM Model Keywords:
Cc: Platform: Monsoon2
UM Version: 10.9

Description

Dear CMS,

My runs on MONSooN2 crashed with the following error:

[WARN] Mule Module is not available. um-pumf will be used.
[WARN] Iris Module is not available
[WARN] [SUBPROCESS]: Command: /projects/um1/vn10.9/xc40/utilities/um-pumf -h /home/d04/sanic/cylc-run/u-bg324/log/job/20060101T0000Z/postproc/10/job-pumfhead.out /home/d04/sanic/cylc-run/u-bg324/share/data/History_Data/bg324a.pa2005dec
[SUBPROCESS]: Error = 2:

No such file or directory

[ERROR] pumf: Failed to extract header information from file /home/d04/sanic/cylc-run/u-bg324/share/data/History_Data/bg324a.pa2005dec
[FAIL] Command Terminated
[FAIL] Terminating PostProc?
[FAIL] main_pp.py atmos # return-code=1
2019-03-22T14:05:54Z CRITICAL - failed/EXIT

The files it refers to (/home/d04/sanic/cylc-run/u-bg324/share/data/History_Data/bg324a.pa2005dec) do exist. The same error has happened to my suites u-bg323 and u-bg324.

Kind regards,
Scott

Change History (3)

comment:1 Changed 6 months ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Scott,

The "No such file or directory" refers to being unable to find um-pumf.

You need to change you suite to load the um_tools module rather than scitools so that it can use Mule. A change went in earlier this week that removed mule setup from scitools.

In site/MONSooN.rc replace occurences of module load scitools with module load um_tools. The rose suite-run --reload and retrigger the postproc task.

Cheers,
Ros.

comment:2 Changed 6 months ago by scottan

Thanks Ros, that seems to have fixed it.

Cheers,
Scott

comment:3 Changed 6 months ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.