Opened 3 months ago

Closed 2 months ago

#2843 closed help (answered)

UM modules not found

Reported by: s1895566 Owned by: willie
Component: SCM Keywords:
Cc: Platform: Other
UM Version: 11.2

Description

Tried to run u-bf475, a single column model on Eddie, a university server, and got the following error.

ModuleCmd_Use.c(231):ERROR:64: Directory '/usr/local/um/modulefiles' not found ModuleCmd_Load.c(208):ERROR:105: Unable to locate a modulefile for 'um-intel'

Does that mean some UM modules are missing? Any idea how to solve it, say what should be installed on Eddie? Alternatively, is there a better single column model suite to use? Thanks!

Change History (2)

comment:1 Changed 3 months ago by willie

  • Component changed from UM Model to SCM
  • Owner changed from um_support to willie
  • Status changed from new to accepted

Hi,

Getting the SCM to run on a computer like Eddie will be quite time consuming. You would need,

  • an installation of FCM, Rose and Cylc
  • a version of MPI
  • a Fortran 2003 compiler
  • a build of GCOM
  • a build of the shared UM library
  • a version of netCDF


I have recently gotten the SCM to work on ARCHER and I think it would be quicker for you to start there. My suite is at 11.1 and is GA7 TOGA_COARE, like your u-bf475. The suite id is u-bf976. This is a work-in-progress, but you should just be able to check out revision 110285 and run it. You will need and account on ARCHER.

Willie

comment:2 Changed 2 months ago by willie

  • Resolution set to answered
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.