Opened 2 weeks ago

Closed 11 days ago

#2858 closed help (fixed)

Error when using my own SST and Sea ice ancillary file

Reported by: zliu Owned by: um_support
Component: UM Model Keywords: ancillary, creation, STASH code
Cc: Platform: ARCHER
UM Version: 10.7

Description

Hi,

The suite is u-bh589. I tried to run some nudging experiments with my own produced SST and Sea ice ancillary file. But the atmos_main crash quickly with the error as follows:
????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!
? Error code: 202
? Error from routine: UP_ANCIL
? Error message: REPLANCA: PP HEADERS ON ANCILLARY FILE DO NOT MATCH
? Error from processor: 74
? Error number: 15
????????????????????????????????????????????????????????????????????????????????
The log file is under /home/zliu/cylc-run/u-bh589/log/job/19810901T0000Z/atmos_main/01
Could you please help?
Thanks.

zhen

Change History (9)

comment:1 Changed 2 weeks ago by zliu

The daily ancillary files are ERA_SEAICE.anc and ERA_SST_365.anc under /home/n02/n02/zliu/work/INPUTFILES. Thanks.
zhen

comment:2 Changed 2 weeks ago by willie

Hi Zhen,

Go to um→ env → Run time controls → Atmosphere Only and set PRINT STATUS to "extra diagnostic information".

Then go to um→ namelist → IO system settings → print Manager control and set prnt_force_flush to true.

Set the privilege on the SST so we can read it,

chmod g+rX /work/n02/n02/zliu/INPUTFILES/ERA_SST_365.anc

Then try your run again. This will give you more information to diagnose the problem.

Willie

comment:3 Changed 2 weeks ago by zliu

Hi Willie,

Great to receive your replies.
I have changed the privilege on both the SST and Seaice. The simulation has been resubmitted. I will let you know once the simulation is finished.
Thanks.
zhen

comment:4 Changed 2 weeks ago by zliu

Hi Willie,

The job finished with the same error. I still cannot find what is the problem. Thanks.

zhen

comment:5 Changed 2 weeks ago by willie

  • Cc ancillary, creation added

Hi Zhen,

Your SST file is on a different grid from the model start dump. If you look at them in xconv you will see that the SST has a first longitude of 0.937500 deg while the start dump has 0 deg - click on a field in xconv and select "Trans" at top right.

The ancillaries must be on exactly the same grid as the model. See section 5.8 of the UM Basic User Guide and also https://code.metoffice.gov.uk/doc/ancil/ancil9.1/index.html.

So you will need to recreate your ancillary file.

Willie

comment:6 Changed 2 weeks ago by zliu

Hi Willie,

Thanks for your feedback.
But I use a different SST ancillary file before with starting longitude of 0.937500 deg. It works actually which can be proved in the suite u-bh611 (a copy of u-bh589). So this may not be the problem. I am not sure.
You can find the sst ancillary file (SST_365.anc, this is a commonly used sst ancillary file on Archer) is under /home/n02/n02/zliu/work/INPUTFILES.

zhen

comment:7 Changed 2 weeks ago by zliu

From the website you sent to me, I found the stash code of SST is 24 (https://code.metoffice.gov.uk/doc/ancil/ancil9.1/ASDP/ASDP04.html#sea-surface-temperature-processing). But from the STASH file (/home/n02/n02/zliu/cylc-run/u-bh589/work/19810901T0000Z/atmos_main/STASHmaster_A) I used for making ancillary, the code of sst is 507 as follows
1| 1 | 0 | 507 |OPEN SEA SURFACE TEMP AFTER TIMESTEP|
2| 2 | 0 | 1 | 1 | 5 | -1 | -1 | 0 | 0 | 0 | 0 |
3| 000000000000100000000000000000 | 00000000000000000001 | 3 |
4| 1 | 2 | -3 -10 -3 -3 -10 21 -3 -99 -99 -99 |
5| 0 | 16 | 0 | 129 | 0 | 0 | 0 | 9999 | 18 |
I think most likely I choose the wrong stash code for SST ancillary variables? If the stash code is 24, the code in STASHmaster_A looks like
1| 1 | 3 | 24 |SURFACE TEMPERATURE AFTER B.LAYER |
2| 7 | 24 | 1 | 1 | 5 | -1 | -1 | 0 | 0 | 0 | 0 |
3| 000000000000000000000000000000 | 00000000000100000001 | 3 |
4| 1 | 2 | -3 -10 -3 -3 -14 21 -3 -99 -99 -99 |
5| 0 | 16 | 3 | 129 | 0 | 0 | 0 | 9999 | 18 |

This variable is not like the SST variable to me. Thanks.
zhen

comment:8 Changed 2 weeks ago by zliu

Hi Willie,

The problem is solved. It is the stash code problem. Sorry for my stupid mistake. Please feel free to close the ticket and thanks for your help.

Cheers,
zhen

comment:9 Changed 11 days ago by willie

  • Cc ancillary, creation removed
  • Keywords ancillary, creation, STASH code added
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.