Opened 11 years ago

Closed 11 years ago

#286 closed help (fixed)

ERROR: bi_linear_h warning over-writing due to dim_e_out size

Reported by: swr01hfd Owned by: willie
Component: UM Model Keywords: lan-sea mask, reconfiguration
Cc: Platform:
UM Version: 6.1

Description

Hi

I'm trying to run a nested series of UM vn6.1 limited area domains on Hector (job xeakd). I downloaded the umui example job (xcxda) and changed the username etc. This job ran ok. I then changed the input start dump to one I've generated from ECMWF data (xeakb.astart) and this causes the model to crash. The error in the .leave file is a segmetation fault

Segmentation fault! Fault address: (nil)

This is likely to have been caused by either a null pointer dereference or a general protection fault.
_pmii_daemon(SIGCHLD): PE 24 exit signal Aborted

I've had a look in the .pe24 file and the error is: bi_linear_h warning over-writing due to dim_e_out size 25760

Any ideas what might be causing the model to crash at the second timestep?

Thanks
Helen

Change History (4)

comment:1 Changed 11 years ago by willie

  • Owner changed from um_support to willie
  • Status changed from new to accepted

Hi Helen,

I have generated a new ECMWF file for you 19941023_00.grib and reconfigured it to 50 levels using a job similar to xdkeb. For reference the bilinear switch can be found on the start dump page under "using the reconfiguration", though you shouldn't need it now.

regards,

Willie

comment:2 Changed 11 years ago by willie

Hi Helen,

I have now generated an LBC based on your job xeakd. This was created from ECMWF ERA-I start dumps at 6 hrly intervals over two days using the makebc program. It is in /work/n02/n02/wmcginty/test_makebc if you want to play with it.

I am still trying to get ot the bottom of this error.

Regards,

Willie

comment:3 Changed 11 years ago by willie

  • Keywords lan-sea mask, reconfiguration added

Hi Helen,

I now have a solution. The solution was incredibly simple: just configure the ancillary land

sea mask during reconfiguration. The best technique for solving this
problem was to dump every timestep: it was then clear that various
fields had Nans round the coast lines. This pattern was reflected in a
similar difference between the ECMWF land-sea mask (1440x721x1) and the
ancillary N320 land-sea mask (640x481x1).

Regards,

Willie

comment:4 Changed 11 years ago by willie

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.