Opened 4 months ago

Closed 3 weeks ago

#2876 closed help (fixed)

atmos_main error after changing start time using UM10.7

Reported by: zliu Owned by: um_support
Component: UM Model Keywords: meaning
Cc: Platform: ARCHER
UM Version: 10.7

Description

Hi,

I am running GA7.1 simulations with UM10.7. The suite id is u-bh862 copied from u-bh589. Suite u-bh589 can run successfully starting from 19810901 with start dump on 01/09/1981. But the u-bh862 crash after I only change the start time to 01/09/1992. I also tried change start dump on 01/09/1988, the simulation still crashed. It failed with information as follows under ~/work/cylc-run/u-bh862/log/job/19920901T0000Z/atmos_main

Error message: Error in buffin errorCode= 0.00 len=0/1536
Error message: ACUMPS1: Partial sum file inconsistent. See Output

I have found two related ticket before, #2425 and #2163. I have included the branch to fix the gregorian climate meanings. Because of my UM version 10.7, I think I cannot use the way in #2163 based on information from website http://www.ukca.ac.uk/wiki/index.php/Nudging. The website told me there is a bug in the UM between UM10.3 and UM10.9.

Could you please help me to solve this issue. Thanks.

Best regards,
zhen

Change History (6)

comment:1 Changed 4 months ago by zliu

I got an update. I change the start dump to /work/n02/n02/nfreyche/STARTDUMP/ab475a.da20121201_00. Then it seems to me the model works with start date 01/12/1992 as the model has run about ten hours.
The size of ab475a.da20121201_00 is 3.5G, which is larger than the file ab357a.da19810901_00 (2.8G) and ab642a.da19880901_00 (3.3G) I used before under /home/n02/n02/zliu/work/INPUTFILES/initial_conditions. I am not sure whether this is the problem.
Could you please create a dump file similar to ab475a.da20121201_00 but with date 01/09/1992. If not possible with this particular year, please create a start dump with the earliest year and date 01/09. I cannot use grib as start dump as my UM version is 10.7. Thanks

Best,
zhen

comment:2 Changed 4 months ago by willie

Hi Zhen,

I have started to look at u-bh862. Could you let me have read permission on /work/n02/n02/zliu/INPUTFILES/ERA_SEAICE.anc please. If you,

chmod 644 /work/n02/n02/zliu/INPUTFILES/*

this will catch any other input file that may be necessary. Thanks.

Willie

comment:3 Changed 4 months ago by zliu

Hi Willie,

Thanks for your message. I have changed the permission.

zhen

comment:4 Changed 4 months ago by willie

  • Keywords meaning added

Hi Zhen,

If you change the model basis time, then you need to change the mean reference time to match, otherwise you will be attempting to compute a mean over a 10 year period. See the document C05 "Control of Means calculation".

If you change the mean reference time (um → namel;ist → Model Input and Output → Dumping and Meaning) so that the year is 1992, it will then work as expected.

Willie

comment:5 Changed 4 months ago by zliu

Hi Willie,

I still get a question. If it is the problem of year in the reference time, why startdump ab475a.da20121201_00 works with the reference time (01/12/1981) I used.
I am wondering whether it is the problem of month and day in the date rather than the year.
Thanks.

zhen

comment:6 Changed 3 weeks ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.