Opened 7 months ago

Closed 7 months ago

#2901 closed help (fixed)

suites seem to have stopped running

Reported by: ChrisWells Owned by: um_support
Component: UM Model Keywords:
Cc: Platform:
UM Version:

Description

Hi,

I have a few suites running for some time, but when I logged in just now I did qstat and got nothing in return. If I do gcylc on a suite which I ran, I get "stopped on running".

I tried to do rose suite-run commands (was unsure which to use) but got some odd answers:

chwel@xcslc0:~/roses/u-bi228> rose suite-run --restart
[FAIL] Suite "u-bi228" appears to be running:
[FAIL] Contact info from: "/home/d00/chwel/cylc-run/u-bi228/.service/contact"
[FAIL]     CYLC_SUITE_HOST=xcslc1
[FAIL]     CYLC_SUITE_OWNER=chwel
[FAIL]     CYLC_SUITE_PORT=43055
[FAIL]     CYLC_SUITE_PROCESS=144903 /usr/bin/python2 /common/fcm/cylc-7.8.1/bin/cylc-run u-bi228 --host=localhost
[FAIL] Try "cylc stop 'u-bi228'" first?
chwel@xcslc0:~/roses/u-bi228> gcylc u-bi228 &
[3] 78442
chwel@xcslc0:~/roses/u-bi228> rose suite-run --reload
[FAIL] u-bi228: does not appear to be running
chwel@xcslc0:~/roses/u-bi228>

So the host doesn't seem to know if the suite is running or not. Do you know what I should do to continue these suites?

Cheers,
Chris

Change History (3)

comment:1 Changed 7 months ago by ChrisWells

Just for more context if useful, I ran a new suite just now and it seems to have worked - it's running in gcylc and comes up on qstat too.

comment:2 Changed 7 months ago by ros

Hi Chris,

Please try doing as it says and run:

cylc stop 'u-bi228'

Then try running rose suite-restart

If it still thinks it's running, then please try following the instructions at https://collab.metoffice.gov.uk/twiki/bin/view/Support/MONSooNRose#Restarting%20Rose%20suites to force kill the suite and then restart it.

Regards,
Ros.

comment:3 Changed 7 months ago by ChrisWells

  • Resolution set to fixed
  • Status changed from new to closed

Hi Ros,

My bad - I should have done that but was unsure due to the conflicting errors. That seems to have worked fine, so I'll close this now.

Cheers,
Chris

Note: See TracTickets for help on using tickets.