Opened 3 months ago

Last modified 3 weeks ago

#2918 new help

initialise a UKCA tracer from a netcdf file

Reported by: emb66 Owned by: um_support
Component: UM Reconfiguration Keywords: initialisation, ncdf file
Cc: Platform: ARCHER
UM Version: 11.0

Description

Dear CMS,

I'm trying to initialise a number of UKCA tracers (STASH 34055-34057, 34099-34100),
but instead of using the default values in the start dump (ainitial) I want to read the values
for these from external netcdf files.

I've included these tracers into the table in
um → Reconfiguration and Ancillary control → Configure ancils and initialise dump fields
trying selecting various options for their source, but I keep getting errors during the reconfiguration.

I've also tried converting a netcdf file to a UM format atmosphere multi-level ancillary file
using xancil but than keeps failing too (see /work/n02/n02/emb66/CFC11.job).

Any idea which source option should I select in rose (u-bi807; also what are the requirements for a netcdf file to be read in - does it need to follow cf convention?),
or how to correctly set up xancil?

Thank you!
Ewa


Change History (10)

comment:1 Changed 2 months ago by grenville

Ewa

Is this still a problem?

Grenville

comment:2 Changed 2 months ago by emb66

Hi Grenville,

Yes, it is, I'm afraid.

Thank you,
Ewa

comment:3 Changed 2 months ago by grenville

Please tell us which suite.

comment:4 Changed 2 months ago by luke

Hi Ewa,

I've never initialised UKCA (or indeed, any) tracers using a NetCDF file. I've only ever used Xancil to generate tracer initial conditions.

I would suggest using Xancil to prevent errors. See

For more information. You will need to specify the vertical levels from the namelist the model uses.

If you must persist with NetCDF then the Reconfiguration UMDP (https://code.metoffice.gov.uk/doc/um/latest/papers/umdp_302.pdf) mentions NetCDF in passing:

"Set from NetCDF. This is useful if a user-netcdf file has been specified in 
development of new schemes. In normal use, the netCDF file is pointed to 
within the corresponding ITEMS namelist."

The "specified in development of new schemes" bit makes me think it won't work.

Thanks,
Luke

comment:5 Changed 5 weeks ago by emb66

Hi Luke, Grenville,

So I've managed to turn my netcdf file to an ancillary format file with Xancil. In the
→ um → Reconfiguration and Ancillary control → Configure ancils and initialise dump fields
section of rose, I've tried initialising the UKCA tracer in question (STASH 34055) to source=2 (i.e. "ancillary file") but I get an error during the reconfiguration:

????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!
? Error code: 30
? Error from routine: REPLANCA_RCF_REPLANCA
? Error message: replanca_rcf_replanca: ERROR - FIELD 34055 omitted in field,stashcode tests
? Error from processor: 14
? Error number: 3
????????????????????????????????????????????????????????????????????????????????

I've also tried initialising with source=7 (ie. "external file"). In this case, the reconfiguration suceeds, but the model is then crashing at the very beginning of the atmos job with a segmentation fault (see /home/emb66/cylc-run/u-bi807/log/job/19880901T0000Z/atmos_main/NN/job.err on puma).

Any idea which source option should I use, or whether I'm missing something crucial in my *.anc file?

The rose suite is u-bi807.

Thank you!

Ewa

comment:6 Changed 4 weeks ago by grenville

Hi Ewa

It looks like you have fixed this?

Grenville

comment:7 Changed 4 weeks ago by emb66

Hi Grenville,

I've managed to convert my file to a UM format with xancil, yes.

However, I still can't figure out how to correctly set up things in Rose so that UM will successfully initialise one of its UKCA tracers with the values in my new UM format file and carry on running.

Depending on what option I select in
→ um → Reconfiguration and Ancillary control → Configure ancils and initialise dump fields
the UM crashes either on reconfiguration or atmospheric step (see above).

Do you have any suggestions how to fix it, please (suite-id u-bi807)? Is there an example suite somewhere by any chance that successfully initialises a UKCA tracer with an external file that I could take a look at and compare to?

Thank you!
Ewa

comment:8 Changed 3 weeks ago by luke

Hi Ewa,

I think that the main issue here is that, while you have made the correct changes to the stash_testmask.py file, equivalent changes have not been made to tstmsk_ukca_mod.F90. Without this your tracers won't be turned on correctly.

Also, you should be using vn11.0 and not HEAD for your metadata in your branch and suite, and you also need to update the revision number in the fcm_make_um app to the latest (which will need to change again when you have made the changes above).

This is a rather complicated and technical thing to do I'm afraid. The file itself it correctly initialised in Rose I think - the problem is in fact further down the line as it doesn't know that 34055 is on for your new scheme. In fact it's likely that no n9 tracers are being turned on, it's just that this is the first place it falls over, if that makes sense!

Thanks,
Luke

comment:9 Changed 3 weeks ago by luke

Additionally, by

Also, you should be using vn11.0 and not HEAD for your metadata in your branch and suite

I mean that in your suite this is specified as the metadata location at the top of the app/um/rose-app.conf file and also for the STASHmaster location near the top of your rose-suite.conf file. These both need to point to vn11.0 and you need to make sure that the metadata is consistent between these two places (with any changes taken from the HEAD directory as appropriate). Currently these point to different branches/locations so you must manually ensure consistency.

Thanks,
Luke

comment:10 Changed 3 weeks ago by emb66

Hi Luke,

Thank you for that.

I did make changes to the tstmsk_ukca_mod.F90, it’s just that I seem to have made a lot of commits to this branch, so the oldest ones don’t show automatically on the first page in Trac (so you need to change the number of commits per page setting to see it). See vn11.0_double_extended_StratChem [53340:53929] for the relevant changes. I’ve run a fairly long job recently under similar set-up without any obvious problems with the n9 tracers.

Regarding the metadata, I’m using a copy of the vn11.0 release job which on Archer uses a metadata from
/home/ukca/meta/vn11.0_ukca_linox_tweaks/rose-meta/um-atmos/HEAD
I’ve copied the metadata directory as it was over to my /home and edited to account for my user changes to the chemistry scheme (so there is no vn11.0).

The fcm_make_um app in my rose suite points to vn11.0.

The STASHmaster_A file is identical between the one in the meta path and the one in
/home/emb66/vn11.0_double_extended_StratChem/rose-meta/um-atmos/vn11.0/etc/stash/STASHmaster
The reason why I point rose to the later is that it’s inside my fcm directory so it’s committed (unlike the one under the meta= path).

I believe all of the above should be OK?

Having said that all, now that you’ve mentioned my tracer initialisation looks fine, I’ve realised it isn’t the tracer initialisation that is still causing the problem as I’ve previously assumed, but one of the other external/input files (not sure yet which one but I’ll find out) – my job runs fine if it’s only the 35055 tracer that I overwrite the initialisation.

I think that sorts the problem for now, I’ll come back to you in case I need any further help.

Thank you!

Ewa

Last edited 3 weeks ago by emb66 (previous) (diff)
Note: See TracTickets for help on using tickets.