Opened 7 months ago

Closed 7 months ago

#2935 closed help (fixed)

mosrs password does not cache

Reported by: awright Owned by: pmcguire
Component: JULES Keywords:
Cc: Platform: JASMIN
UM Version:

Description

Hello Patrick,

My mosrs password does not cache, it happened after I changed my password on the Met Office repository website. I googled the problem and found a similar case (http://cms.ncas.ac.uk/ticket/1968). I deleted /home/users/azin/.subversion/auth/svn.simple
2be6a67d04b1c8c6d879daafa52fd762, and now when I type : mosrs-cache-password
, I get this error:

svn: E215004: Authentication failed and interactive prompting is disabled; see the —force-interactive option
svn: E215004: Unable to connect to a repository at URL 'https://code.metoffice.gov.uk/svn/test'
svn: E215004: No more credentials or we tried too many times.
Authentication failed
Error: Unable to access Subversion with given password
Run "mosrs-cache-password" to try caching your password again

I think I have to create the authorization file again. Would you know how to do that?

All the best,

Azin

Change History (5)

comment:1 Changed 7 months ago by awright

Hello Patrick,

Just tried again now, and my password is cached. So apparently the problem is resolved without me doing anything?!

All the best,

Azin

comment:2 Changed 7 months ago by pmcguire

Excellent!
Did you log out and log in again? Sometimes that is the easiest way to fix it.
But you might be able to type . mosrs-cache-password (the period with a space might be necessary).
Patrick

comment:3 Changed 7 months ago by pmcguire

  • Status changed from new to accepted

comment:4 Changed 7 months ago by awright

Yes, I logged in and out, but I had done that several times before along with opening a new terminal each time, and it had not worked. I think the hour in between the two loggings might have helped.

Thank you very much,

Azin

comment:5 Changed 7 months ago by pmcguire

  • Resolution set to fixed
  • Status changed from accepted to closed

I will close the ticket now, since it's working for you now.
Patrick

Note: See TracTickets for help on using tickets.