#2966 closed help (fixed)

ImportError: No module named um_utils.fixframe

Reported by: nx902220 Owned by: ros
Component: UM Model Keywords: Mule
Cc: Platform: Monsoon2
UM Version:

Description

Hi,

I have just run my suite u-bc220 for the first time in 5 months and back then there were no errors.

I am getting the same error as I was getting a while ago in ticket
http://cms.ncas.ac.uk/ticket/2571#comment:6

The error occurs in ukv_start. The fix back then was to use
mule-fixframe $ROSE_DATAC/ukv_frame $ROSE_DATAC/ukv_frame_createbc

but that doesn't seem to work anymore.

Please can you help me out with this?

Best wishes,

Lewis

Change History (5)

comment:1 Changed 12 months ago by ros

  • Keywords Mule added
  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Lewis,

I think this is due to a module change. Please try loading um_utils module rather than scitools in your suite.rc file.

Regards,
Ros.

comment:2 Changed 12 months ago by nx902220

Hi Ros,

Thanks for getting back to me.

I tried and it still fails at the same place with:

ModuleCmd_Load.c(226):ERROR:105: Unable to locate a modulefile for 'um_utils'
Traceback (most recent call last):

File "/common/um1/bin/mule-fixframe", line 9, in <module>

load_entry_point('um-utils==2017.08.1', 'console_scripts', 'mule-fixframe')()

File "/opt/python/gnu/2.7.9/lib/python2.7/site-packages/distribute-0.6.28-py2.7.egg/pkg_resources.py", line 337, in load_entry_point

return get_distribution(dist).load_entry_point(group, name)

File "/opt/python/gnu/2.7.9/lib/python2.7/site-packages/distribute-0.6.28-py2.7.egg/pkg_resources.py", line 2311, in load_entry_point

return ep.load()

File "/opt/python/gnu/2.7.9/lib/python2.7/site-packages/distribute-0.6.28-py2.7.egg/pkg_resources.py", line 2017, in load

entry = import(self.module_name, globals(),globals(), __name__?)

ImportError?: No module named um_utils.fixframe
2019-07-25T08:43:48Z CRITICAL - failed/EXIT

Best wishes,

Lewis

comment:3 Changed 12 months ago by ros

Hi Lewis,

Sorry my mistake that should have said module load um_tools.

Cheers,
Ros.

comment:4 Changed 12 months ago by nx902220

Hi Ros,

That is great thank you. Fixed :)

Lewis

comment:5 Changed 12 months ago by ros

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.