#2969 closed help (answered)

Segmentation fault errors

Reported by: scottan Owned by: um_support
Component: UM Model Keywords: UKCA
Cc: Platform: Monsoon2
UM Version: 10.9

Description

Hello,

I am having problems with recurring segmentation fault errors that I can't seem to get to the bottom of. I am rerunning a version of a suite I ran previously to do some sensitivity studies. The suite I am running is u-bl140, which was copied from u-bg325. The only changes have been to update the suite so it can run on MONSooN2 after the upgrade to xcslc1, whereas bg325 was run before these changes.

Currently, the model always chases after one hour of integration with no clear error message:

[303] exceptions: An exception was raised:11 (Segmentation fault)
[303] exceptions: the exception reports the extra information: Sent by the kernel.
[303] exceptions: whilst in a serial region
[303] exceptions: Task had pid=55475 on host nid01772
[303] exceptions: Program is "/home/d04/sanic/cylc-run/u-bl140/share/fcm_make_um/build-atmos/bin/um-atmos.exe"

At first I was running from a later start dump, but I have gone back and tried to recreate the exact same setup as was originally used to make the bg325 runs, with the same source code used at the time, and I still get the same error.

Any help or advise welcome here, at it is both holding up my work and undermines the reproducibility of my results, which is a big worry.

Many thanks,
Scott

Change History (3)

comment:1 Changed 11 months ago by grenville

Scott

I can not find suite u-bl140 in your Monsoon space?

Grenville

comment:2 Changed 11 months ago by scottan

hi Grenville,

Apologies, I ended up getting help with this from Mohit and fixed the problem. I then deleted the suite bl140 as I was only using it for testing and debugging. Please feel free to close this ticket.

Kind regards,
Scott

comment:3 Changed 11 months ago by grenville

  • Resolution set to answered
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.