#2970 closed help (fixed)

Adjusting Decomposition

Reported by: ChrisWells Owned by: um_support
Component: UM Model Keywords:
Cc: Platform:
UM Version:

Description

Hi,

I'm trying to turn the ocean off in a UKESM run (u-bl128), but when I switch off the coupler I get the message

UM started on     690 PEs but     576 asked for. Please adjust decomposition

I think this is because in Domain Decomposition, the atmosphere is 32*18 = 576 , and ocean is 9*12 = 108, plus 6 for the coupler is 114, making 690 total.

So I guess the model is still trying to model the ocean, as I've only turned the coupler off, but is only requesting enough processors for the atmosphere. Turning off Build Ocean doesn't fix this.

Do you know how I can make the model run without the ocean? I've also given it sst and sea ice ancil files, plus dms and chlorophyll (from AMIP for now).

I'm not sure if this is a specific UKESM question or can be answered generally so I've left it untagged.

Cheers,
Chris

Change History (3)

comment:1 Changed 10 months ago by ros

Hi Chris,

Turning off the ocean in a coupled suite is not that simple. Is there any reason why you can't use the UKESM AMIP suite u-be303?

Regards,
Ros.

comment:2 Changed 10 months ago by ChrisWells

Hi Ros,

I thought about that, but I wanted to be certain the physics was the same, especially aerosols and chemistry.

If I pick the Chemistry AeroClim? in Aerosol Configuration in Model Configuration, and then ukca_em_files in Section 34, will this allow me to input emissions files to it as for UKESM? If so then I'll do that.

Many thanks,
Chris

comment:3 Changed 10 months ago by ChrisWells

  • Resolution set to fixed
  • Status changed from new to closed

Hi Ros,

Apologies for the confusion; I've spoken to Mohit and he's told me that the default AMIP (Prognostic aerosols) is the same science configuration as UKESM in the atmosphere. I'll close this ticket and use that suite.

Cheers,
Chris

Note: See TracTickets for help on using tickets.