#2982 closed help (fixed)

Nudging without temperature

Reported by: Leighton_Regayre Owned by: um_support
Component: UM Model Keywords: nudge nudging temperature datapath ARCHER
Cc: Platform: PUMA
UM Version: 11.1

Description

Hello,

In my suite u-bk417 I am attempting to nudge towards ECMWF wind fields, without nudging to temperatures.

My recon task fails with the error:
[FAIL] namelist:run_nudging=ndg_datapath: NUDGE_DATA: unbound variable
[FAIL] source: namelist:run_nudging
Received signal ERR

I don't think this is related to my choice of relaxation value for temperature (ndg_relax_tvalue) because I get the same error when I change the value from 0 to 1e-15 (a similar strategy to ticket #2319).

Is it possible that the datapath is not set correctly? I copied this datapath from a colleague's suite which is set up to run on monsoon.

Thanks,

Leighton.

Change History (3)

comment:1 Changed 11 months ago by ros

Hi Leighton,

You need to figure out what path you need to set ndg_datapath to. Currently you have it set to an environment variable $NUDGE_DATA. You either need to replace this with the correct path on ARCHER or define the value of NUDGE_DATA in the suite. You say you've copied this from a colleague's suite on Monsoon2. I suggest you look at their suite and find out what this variable is set to there and adjust to suit for ARCHER.

Regards,
Ros.

comment:2 Changed 11 months ago by Leighton_Regayre

Hi Ros,

Thanks for clarifying the problem is with the path, not the temperature relaxation. Mohit directed me towards standard free-running and nudged suites on all platforms https://www.ukca.ac.uk/wiki/index.php/GA7.1_StratTrop_suites so I've used the suite u-bb210 to set the ndg_datapath to /work/n02/n02/ukca/analyses/era-in for ARCHER use.

Cheers,

Leighton.

comment:3 Changed 11 months ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.