#2986 closed help (fixed)

Archive integrity error

Reported by: charlie Owned by: ros
Component: UM Model Keywords:
Cc: Platform: NEXCS
UM Version: 10.7

Description

Hi,

Sorry to bother you again, but I am getting an error at the "archive_integrity" stage on my suite, which I haven't seen before with this suite. I saw this error briefly with another suite a couple of years ago, and you said I wasn't using it so it didn't matter.

My current suite (u-bk944) has already run 10 years successfully, has moved onto year 11, and appears to have transferred year 10 to JASMIN, as it should. Does that mean I can just ignore this error, or will it snarl up everything else? The exact error I'm getting is:

[WARN] file:atmospp.nl: skip missing optional source: namelist:moose_arch
[WARN] file:nemocicepp.nl: skip missing optional source: namelist:moose_arch
[WARN]  [SUBPROCESS]: Command: moo ls -r moose:crum/u-bk944
[SUBPROCESS]: Error = 255:
	ls: cannot access /home/d05/cwilliams/.moosedir/moose: No such file or directory
Unable to load Moose credentials. Please check credential file permissions. Only file owner should have read and write access 

[WARN]  Collection ada.file is missing from the archive.
[WARN]  Collection ap4.pp is missing from the archive.
[WARN]  Collection ap5.pp is missing from the archive.
[WARN]  Collection ap6.pp is missing from the archive.
[WARN]  Collection ap7.pp is missing from the archive.
[WARN]  Collection ap8.pp is missing from the archive.
[WARN]  Collection ap9.pp is missing from the archive.
[WARN]  Collection apa.pp is missing from the archive.
[WARN]  Collection apb.pp is missing from the archive.
[WARN]  Collection apc.pp is missing from the archive.
[WARN]  Collection apd.pp is missing from the archive.
[WARN]  Collection ape.pp is missing from the archive.
[WARN]  Collection apf.pp is missing from the archive.
[WARN]  Collection apg.pp is missing from the archive.
[WARN]  Collection api.pp is missing from the archive.
[WARN]  Collection apj.pp is missing from the archive.
[WARN]  Collection apk.pp is missing from the archive.
[WARN]  Collection apl.pp is missing from the archive.
[WARN]  Collection apm.pp is missing from the archive.
[WARN]  Collection apn.pp is missing from the archive.
[WARN]  Collection aps.pp is missing from the archive.
[WARN]  Collection apu.pp is missing from the archive.
[WARN]  Collection apy.pp is missing from the archive.
[WARN]  Collection ida.file is missing from the archive.
[WARN]  Collection ind.nc.file is missing from the archive.
[WARN]  Collection inm.nc.file is missing from the archive.
[WARN]  Collection ins.nc.file is missing from the archive.
[WARN]  Collection iny.nc.file is missing from the archive.
[WARN]  Collection oda.file is missing from the archive.
[WARN]  Collection ond.nc.file is missing from the archive.
[WARN]  Collection oni.nc.file is missing from the archive.
[WARN]  Collection onm.nc.file is missing from the archive.
[WARN]  Collection ons.nc.file is missing from the archive.
[WARN]  Collection ony.nc.file is missing from the archive.
[FAIL]  Dataset incomplete - holes present in moose:crum/u-bk944
[FAIL] Terminating PostProc...
[FAIL] archive_integrity.py # return-code=1
2019-08-12T13:17:30Z CRITICAL - failed/EXIT

Many thanks,

Charlie

Change History (5)

comment:1 Changed 11 months ago by ros

Hi Charlie,

The archive_integrity app only works with data that is being put into MASS. You should switch this task off in the suite.

Cheers,
Ros.

comment:2 Changed 11 months ago by charlie

Many thanks Ros. Am I correct in thinking that I turn this off within suite conf > Build and run > Postproc app? If so, which one do I switch to False? There are several options: Split postprocessing app by model (currently True), Wallclock time (currently 3 hours), Archive_integrity postproc app gap checker (currently True), and Archive_integrity gap checker frequency (currently 10 years).

Once I have done this, do I need to reload or restart the suite?

Last question: why, given that this is always been turned on, did the error only 10 years into my suite?

Thanks,

Charlie

comment:3 Changed 11 months ago by ros

  • Owner changed from um_support to ros
  • Status changed from new to accepted

Hi Charlie,

That would be switching off the "Archive_Integrity - Post Proc App Gap checker" option

Yes, you can just do a rose suite-run --reload. No need to stop and restart the suite.

Your last question you actually answered yourself in your last reply…. ;-) it's set to run every 10 years!

Cheers,
Ros.

comment:4 Changed 11 months ago by charlie

Many thanks, all done.

And yes, sorry, of course - every 10 years. Sorry I didn't see that before!

Many thanks again.

Charlie

comment:5 Changed 11 months ago by charlie

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.