Opened 5 weeks ago

Closed 5 days ago

#2995 closed help (answered)

Monthly mean output with nudged simulations

Reported by: Leighton_Regayre Owned by: um_support
Component: UM Model Keywords: nudge Gregorian pp output stream
Cc: Platform: PUMA
UM Version: 11.1

Description

Hello,

I need monthly mean output from nudged simulations for comparison of model output with measurements. Following advice on ticket #2933 (Fixed) I have altered the filename base for stash item pp130 from .pm to .pn to avoid confusing the postproc script. However, there are problems with the output I need to address.

This ticket relates to suite u-bk417. Output for the suite is here:
/work/n02/n02/lre/cylc-run/u-bk417/share/data/History_Data/

Firstly, I was concerned that the output wouldn't be monthly means for the correct month. I had been warned that using the Gregorian calendar may not produce the monthly means as expected, since means may still be calculated every 30 days. So far as I can tell the time index for the output is on the 15th or 16th of the month in my .pn output, which suggests the Gregorian calendar is being used as intended, since I used the 'real months' option for the 'Model Output Stream'. It would be useful to have this functionality confirmed. Is output with a 15/16 t value being calculated using the Gregorian calendar?

Secondly, only one .pn file is created and is named 'jan'. This file contains data for multiple months. I expected and need a distinct file for each month. However, this file contains data for January, March and April (based on t values from xconv). It is missing February. Clearly, this output stream is not fit for purpose as currently set up. Could you please advise me on what to alter in order to get distinct monthly mean output files?

Thirdly, because I am going to create a large ensemble using a suite similar to this one, I need all output to be archived onto /nerc. I thought I had the suite set up to do this. However, no data is currently archived to /nerc/n02/n02/lre/rose_achiving/ so far as I can tell. Could you please suggest what to change so that my suite archives output as intended?

Thanks,

Leighton.

Change History (8)

comment:1 Changed 5 weeks ago by ros

Hi Leighton,

You currently have stream .pn set to reinitialise every 30 months. Change this to every month and you should then get a new file for each month.

Regards,
Ros.

Last edited 5 weeks ago by ros (previous) (diff)

comment:2 Changed 5 weeks ago by luke

Hi Leighton,

When using the Gregorian calendar, often an optional configuration override file is used which then overrides settings within Rose to ones which are consistent with using a Gregorian calendar. This includes things like how the output streams are considered, and some files etc.

If this file is being used you might find yourself changing things in Rose and they then have no effect, no matter what you do. This is because the override file is applied last and will change settings to what is in the file.

You will likely find this file at

./app/um/opt/rose-app-gregorian.conf

in your suite.

I suggest you look at the settings here and compare to the settings in Rose. This file usually changes how output files are reinitialised so that real months are used, which means that you get proper meaning for 28-, 29-, 30-, and 31-day months. This can also be seen by looking at the date of the month in the file. 30-day months are always dated midnight on the 16th, whereas 31-day months will be 12noon on the 16th etc.

Thanks,
Luke

comment:3 Changed 5 weeks ago by Leighton_Regayre

  • Keywords nudge Gregorian pp output stream added
  • Platform set to PUMA
  • UM Version set to 11.1

Hi Ros, Luke,

Thanks both. That's really useful on both counts. Cheers!

I think my archiving problem was trivial. I had temporarily switched of post processing whilst testing other changes.

Thanks again,

Leighton.

comment:4 follow-up: Changed 5 weeks ago by Leighton_Regayre

Hi Luke,

Having followed Ros's advice I've now got distinct monthly output files (.pn). Files are here:
/work/n02/n02/lre/cylc-run/u-bk417/share/data/History_Data

However, when I view the January file via xconv, the time dimension looks to be at midnight, rather than midday. 2008/01/16:00.00 / 15.0000

Am I getting the correct information by viewing the timestamp using xconv? Is there a better approach?

I've altered my file
/home/Leighton_Regayre/roses/u-bk417/app/um/opt/rose-app-gregorian.conf

so that real months are used throughout. Would you suggest I add similar content for output stream pp130 which is what I'm most interested in?

comment:5 Changed 5 weeks ago by Leighton_Regayre

Ros,

Could you please give me some advice on the postproc archiving for my suite u-bl646?

For some reason the '4', '5' and 'u' streams labelled 'jan' are going into a folder labelled '20080101T0000Z', whilst streams 'a' and 'n' labelled 'jan' are going into a folder labelled '20080201T0000Z' which is presumably for February. My suite gui suggests the simulation has completed the atmos_main, postproc and housekeeping tasks for February, yet I can't see any related output on /nerc/n02/n02/rose-archiving/u-bk417

I'm wondering why the monthly mean outputs for the same month are going to different folders. Also, I'm wondering what's happened to the output for February.

Thanks,

Leighton.

comment:6 in reply to: ↑ 4 Changed 5 weeks ago by Leighton_Regayre

Replying to Leighton_Regayre:

For some reason, this comment didn't send an automatic email.

Hi Luke,

Having followed Ros's advice I've now got distinct monthly output files (.pn). Files are here:
/work/n02/n02/lre/cylc-run/u-bk417/share/data/History_Data

However, when I view the January file via xconv, the time dimension looks to be at midnight, rather than midday. 2008/01/16:00.00 / 15.0000

Am I getting the correct information by viewing the timestamp using xconv? Is there a better approach?

I've altered my file
/home/Leighton_Regayre/roses/u-bk417/app/um/opt/rose-app-gregorian.conf

so that real months are used throughout. Would you suggest I add similar content for output stream pp130 which is what I'm most interested in?

comment:7 Changed 5 weeks ago by ros

Hi Leighton,

The directories on /nerc relate to the post-processing completed for that cylc cycle and does not indicate that the data in that directory is all related to February, for example. The post-processing will archive any files that are no longer needed for the model to run, so not all of January's files will end up in the folder labelled 20080101T0000Z as they may be required to startup the next cycle and thus will be archived at the end of the 20080201T0000Z cycle and be placed in the 20080201T0000Z directory. If you run the model out a few more months you'll get to see a pattern in when different output files are archived.

Hope that helps.
Cheers,
Ros.

comment:8 Changed 5 days ago by grenville

  • Resolution set to answered
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.