Opened 5 months ago

Closed 5 months ago

#3011 closed help (fixed)

ssh-add on puma not working

Reported by: taubry Owned by: um_support
Component: PUMA Keywords: ssh agent, puma
Cc: Platform: PUMA
UM Version:

Description

Hi,

I was asked my passphrase when trying to login to ARCHER, so I tried to re-associate your ssh keys to the agent. ssh-add did not work with error message "Could not open a connection to your authentication agent.". I thus followed instructions from section 11.2 of the UM practical sessions and deleted the environment.puma file. logged out and back in again. When I log in I do see the message "Initialising new SSH agent…" but then ssh-add still fails.

Thanks for any help!

Change History (5)

comment:1 Changed 5 months ago by dcase

You have loads of ssh agents running. You can see them by running:

ps -flu taubry

so as a first step, kill them all then log out and back in again. You should then be able to get one agent, and add to this.

comment:2 Changed 5 months ago by taubry

Hi Dave,

Thanks! I've killed most of them (some just come back when I login to puma) but ssh-add still fails.

comment:3 Changed 5 months ago by dcase

If you kill them all, then log back in again, it should say

Initialising new SSH agent...

and then when you run ssh-add -l

it should say

The agent has no identities.

If it gives you an error about connecting to the agent then things haven't been cleaned up.
Did you get the message about initialising an agent? What was the error that you get this time with the ssh-add? The same as last time?

comment:4 Changed 5 months ago by taubry

Yes, I get the same error message

"Could not open a connection to your authentication agent."

This is after killing all the processes. But then when I logged back in again ps -flu taubry returns

"F S UID PID PPID C PRI NI ADDR SZ WCHAN STIME TTY TIME CMD
5 S taubry 1720 1688 0 80 0 - 8838 ? 16:31 ? 00:00:00 sshd: taubry@pts/2
0 S taubry 1722 1720 0 80 0 - 5023 wait 16:31 pts/2 00:00:00 -ksh
1 S taubry 1749 1 0 80 0 - 5861 ? 16:31 ? 00:00:00 ssh-agent
1 S taubry 1754 1 0 80 0 - 4768 - 16:31 ? 00:00:00 gpg-agent —daemon —allow-preset-passphrase —batch —max-cache-ttl 43200
0 R taubry 2252 1722 0 80 0 - 1214 - 16:32 pts/2 00:00:00 ps -flu taubry"

comment:5 Changed 5 months ago by taubry

  • Resolution set to fixed
  • Status changed from new to closed

Dear Dave,

After doing some cleaning on Puma, ssh-add now work just fine. I'm a bit surprised as my disk was not completely full, but it seem like this was somehow related.

Thanks,

Thomas

Note: See TracTickets for help on using tickets.