#3019 closed help (fixed)

radiation diagnostics and time step

Reported by: amenon Owned by: um_support
Component: UM Model Keywords: radiation
Cc: Platform: ARCHER
UM Version: 10.9

Description

Dear CMS,
I am having issues with radiation outputs from a 1.5 km suite. I use the RA1-T science configuration. Accordingly I use a model time step of 75s, diagnostic radiation time step 375s (5 times model ts) and prognostic radiation time step 1125s (3 times diagnostic ts). I am trying to output the radiation parameters as 1 hour means. All other diagnostics like rainfall are outputted at 00:30Z, 1:30Z etc. However, the radiation diganostics are outputted as 00:28Z, 00:58Z etc. Also the same diagnostic is repeated several times in the same file. As the radiation time step is less than 1 hour (i.e, the time when I am outputting the diagnostic), I don't know how to fix this issue. Could you please help?

Suite id is u-bl938 in Archer. Output is there in cylc-run/u-bl938/share/cycle/20180806T0000Z/INCOMPASS/km1p5/RA1T_qcons/um/ umnsaa_pa000

Same model at 4.4 km resolution correctly outputted these diagnostics (output in /nerc/n02/n02/amenon/u-bl350/field.pp/20180806T0000Z_INCOMPASS_km4p4_RA1T_qcons_pa000.pp). The 4.4 km model had a time step 180s, diagnostic ts 900s and prognostic ts of 2700s. The issue appears only in the 1.5km model.

Thanks,
Arathy

Change History (3)

comment:1 Changed 10 months ago by grenville

Arathy

This behaviour results from the combination of a 75s model time step and the multiples 15 and 5 used for the radiation time steps. Some significant code changes will be required to prevent this behaviour. If you use multiples 18 and 6 instead, I believe the output will be as expected. Can you try that?

Grenville

comment:2 Changed 10 months ago by amenon

Hi Grenville,

Thanks. I tried the multiples 18 and 6 and it worked. Now the outputs are as I expected.

Arathy

comment:3 Changed 10 months ago by grenville

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.