Opened 4 months ago

Closed 4 months ago

#3027 closed help (answered)

2015 onwards ancillaries and BICGSTAB error

Reported by: Leighton_Regayre Owned by: um_support
Component: UM Model Keywords: nudge Gregorian ancillary BICGSTAB NaN
Cc: Platform: ARCHER
UM Version: 11.1

Description

Hello,

I'm having trouble locating the source of some BICGSTAB errors I believe are associated with ancillary files. The errors are of the form:
NaNs? in error term in BiCGstab after 1 iterations

My suite u-bm992 has been adapted from a working suite (itself adapted from the UKESM1 release) to run from 20150101 (on ARCHER), so that I can make an ensemble for a specific year. Wind fields are nudged in the suite and it uses the Gregorian calendar.

The suite uses files in this folder for SST and seaice:
/work/n02/n02/ukca/ancil/n96e/reynolds/n96e_gregorian_1981_2019/

Because it is nudged, it also uses wind fields from:
/work/n02/n02/ukca/analyses/era-in/
However, this is unchanged since the folder contains wind fields through to 2019 and has a file for 20150101.

I've also altered the restart filename:
/work/y07/y07/umshared/ukesm/restarts/bd256a.da20150101_00
and updated the model basis time to match: 20150101T0000Z

All other ancillaries are climatologies so shouldn't be causing NaN errors.

Any advice on how to track down the source of this error would be very welcome. I've run the suite with the highest level of diagnostic output.

Thanks,

Leighton.

Change History (5)

comment:1 Changed 4 months ago by grenville

Leighton

What was the working suite - how does this differ?

Grenville

comment:2 Changed 4 months ago by Leighton_Regayre

Hi Grenville,

The working suite was u-bk417 at revision number 131782. Suite u-bk417 has since been altered to include changes to radiative flux STASH requests as per ticket #3017. These changes have been replicated in this suite (u-bm992). Furthermore, this suite has been altered to run from 20150101 rather than 20080101. No other change shave been applied, apart from the changes outlined earlier to:

1/ SST and seaice ancillaries
2/ restart file
3/ model basis time

Thanks,

Leighton.

comment:3 Changed 4 months ago by Leighton_Regayre

Hi Grenville,

I've been in touch with Mohit and he has advised me to check the Gas MMR settings in the Radiation section of my suite. The values of time-varying MMRs were only defined to 2015. Because the model interpolates between the values for the years, the following data point is needed as well. I'm not testing an adapted version of suite u-bm992 with fixed (to 2015 value) MMRs.

Thanks,

Leighton.

comment:4 Changed 4 months ago by Leighton_Regayre

Hello,

I can confirm that the problem with my suite was caused by the settings for gas MMRs as outlined in comment 3. I'm happy for this ticket to be closed.

Thanks,

Leighton.

comment:5 Changed 4 months ago by grenville

  • Resolution set to answered
  • Status changed from new to closed

Leighton

Thanks for letting us know.

Grenville

Note: See TracTickets for help on using tickets.