Opened 9 months ago

Closed 9 months ago

#3028 closed help (fixed)

Build HPC failing

Reported by: amenon Owned by: um_support
Component: UM Model Keywords: build hps, fcm_make2 fail
Cc: Platform: ARCHER
UM Version: 10.9

Description

Hi,

fcm_make2 of my suite u-bn032 in Archer is failing with the following error:

[FAIL] preprocess-atmos.prop{fpp.defs}[] = C_LONG_INT=c_long_int C_LOW_U=c_low_u FRL8=frl8  LINUX=linux BUFRD_IO=bufrd_io  CRAY_FORTRAN=8004001 GNU_LIBC=2011003  MPL_WTIME=mpl_wtime   C84_1A=c84_1a C95_2A=c95_2a C96_1C=c96_1c C97_3A=c97_3a  UM_JULES=um_jules: bad name-space
[FAIL] preprocess-atmos.prop{no-step-source}[] = preprocess-recon: bad name-space
[FAIL] preprocess-atmos.prop{cpp.defs}[] = C_LONG_INT=c_long_int C_LOW_U=c_low_u FRL8=frl8  LINUX=linux BUFRD_IO=bufrd_io  CRAY_FORTRAN=8004001 GNU_LIBC=2011003  MPL_WTIME=mpl_wtime   C84_1A=c84_1a C95_2A=c95_2a C96_1C=c96_1c C97_3A=c97_3a  UM_JULES=um_jules: bad name-space

I am not understanding what this error means. Could you please help. This suite uses a new set of land ancillaries that I created. Is it something wrong with the ancil generation?

Thanks,
Arathy

Change History (5)

comment:1 Changed 9 months ago by willie

Hi Arathy,

This is a build problem. I just tried it and it worked for me - ARCHER is being quite slow.

Try it again and see it that works.

Willie

comment:2 Changed 9 months ago by amenon

Hi Willie,

I tried it again. Also ran the suite new as it is the first cycle. I still have an error in fcm_make2. The error file is too big. I am pasting here a part of it. It looks like there is something wrong with the Jules configuration, but I don't know what

[FAIL] JULES_SEA_SEAICE_MOD.mod: bad or missing dependency (type=1.include)
[FAIL] JULES_SURFACE_TYPES_MOD.mod: bad or missing dependency (type=1.include)
[FAIL]     required by: ukca_setd1defs_mod.o
[FAIL]     required by: UKCA_SETD1DEFS_MOD.mod
[FAIL]     required by: ukca_main1_mod.o
[FAIL]     required by: UKCA_MAIN1_MOD.mod
[FAIL]     required by: atm_step_4a.o
[FAIL]     required by: u_model_4a.o
[FAIL]     required by: um_shell.o
[FAIL]     required by: um-atmos.exe
[FAIL] JULES_VEGETATION_MOD.mod: bad or missing dependency (type=1.include)
[FAIL]     required by: disturb_veg_category_mod.o
[FAIL]     required by: DISTURB_VEG_CATEGORY_MOD.mod
[FAIL]     required by: initial_4a.o
[FAIL]     required by: u_model_4a.o
[FAIL]     required by: um_shell.o
[FAIL]     required by: um-atmos.exe

comment:3 Changed 9 months ago by willie

Hi Arathy,

I notice the errors in comment#1 are different from the original errors.

It still works for me. Could I suggest doing a clean build:

rose suite-run --new

and see if that works.

Willie

comment:4 Changed 9 months ago by amenon

Hi Willie,

Running it new fixed the problem this time. We could close this ticket.

Thanks,
Arathy

comment:5 Changed 9 months ago by willie

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.