Opened 9 months ago

Closed 9 months ago

#3044 closed help (invalid)

Number of fields exceeds reserved headers

Reported by: ggxmy Owned by: um_support
Component: UM Model Keywords:
Cc: Platform: Monsoon2
UM Version: 11.1

Description

I think this is a common problem and in #2257 the same problem was solved by increasing the reserved_headers size in Model Input and Output → Model Output Streams. I increased it for pp7 from 16000 to 24000 (as in the attached image) because I added requests of plume scavenging for UPH. However the problem persists. Here is the error message;

?  Error code: 4
?  Error from routine: STWORK
?  Error message: STWORK: Number of fields exceeds reserved headers for unit  20
?  Error from processor: 353
?  Error number: 75

Should I increase it further? Or should I increase those for other ones instead/as well? Or would you suggest an alternative solution? Please could I have an advice?

Masaru

Attachments (1)

model_output_streams.jpeg (112.3 KB) - added by ggxmy 9 months ago.

Download all attachments as: .zip

Change History (5)

Changed 9 months ago by ggxmy

comment:1 Changed 9 months ago by ggxmy

suite id is u-bn684

comment:2 Changed 9 months ago by ggxmy

update:
I looked for '20' everywhere and found lines below in job.out;

FILE_MANAGER:          : id   : pp0
FILE_MANAGER:          : Unit :  20 (portio)

So the problem is assoc. with pp0, for which reserved headers were 0? Strange but I increased the reserved header to 16000 and rerun the job anyway. It failed again for the same error but for unit 15.

I increased reserved headers for pp5 from 16000 to 32000 but the run fails for the same reason (unit 15)… I suspect that this is not the true reason and the run may actually be failing for a different reason. What do you think?

Masaru

comment:3 Changed 9 months ago by grenville

Masaru

We cover this as an exercise in our training - see http://cms.ncas.ac.uk/documents/training/November2018/practicals.pdf - search for STWORK: Number of fields exceeds reserved headers for unit 14

Grenville

comment:4 Changed 9 months ago by ggxmy

  • Resolution set to invalid
  • Status changed from new to closed

Sorry I was working on a suite copied from someone else's suite that has been actually never run… so I shouldn't have trusted any of the settings in there. that's why I had a problem after another. I'm closing this ticket.

Masaru

Note: See TracTickets for help on using tickets.