#3057 closed help (fixed)

Suite run from pumatest cannot access branch

Reported by: taubry Owned by: um_support
Component: UM Model Keywords: pumatest, branch
Cc: jjas3@… Platform: ARCHER
UM Version: 11.2

Description

Dear cms support team,

Apologize for bugging you so much these days…
I'm running into a new problem with my suite u-bo142 which again seems related to running it from pumatest. My suite uses the branch branches/dev/johnstauntonsykes/vn11.2_gaus_plume_volc_hal

I was previously running it with the @head version but realized that some changes committed by my project partner in the branch were not effective in the suite. When I instead specify the latest version (@76678), the suite fails at fcm_make_um with error message

[FAIL] svn://pumatest/um.xm_svn/main/branches/dev/johnstauntonsykes/vn11.2_gaus_plume_volc_hal@76678: not found
[FAIL] svn: E160006: No such revision 76678

Revision 76678 of that branch was committed by Johnny Staunton Sykes on his puma test, and we can see it on trac.

Did we miss a reason why I could not use this branch from my pumatest?

Thanks,

Thomas

Change History (8)

comment:1 Changed 11 months ago by dcase

Thomas,
can you go directly to the repository, i.e. not through the mirror?

fcm:um.x rather than fcm:um.xm

comment:2 Changed 11 months ago by taubry

Hi Dave,

I'm not entirely sure where I should change that. Do you mean the config_root_path in the configuration file panel? If so that doesn't work.

Thanks,

Thomas

comment:3 Changed 11 months ago by dcase

Oh, I just meant for this suite.

I think that in rose edit you'll have fcm_make_um > env > Make steps > mirror

Perhaps if you set the mirror to false for this suite it'll provide an easy hack to the mirror not having your source files??

If this doesn't work, I'll try to find out why they aren't there.
Dave

Last edited 11 months ago by dcase (previous) (diff)

comment:4 Changed 11 months ago by taubry

When I set mirror to false (no) there I still get the exact same error.

[FAIL] svn://pumatest/um.xm_svn/main/branches/dev/johnstauntonsykes/vn11.2_gaus_plume_volc_hal@76678: not found

Which is weird as the um.xm suggests it is still looking in the mirror?

comment:5 Changed 11 months ago by dcase

Yes, my cunning hack was rubbish.

The resync'ing of the mirror is currently in process, so set the 'mirror' option back to true, and try again when you can run this command on the terminal:

fcm ls fcm:um.xm/branches/dev/johnstauntonsykes/vn11.2_gaus_plume_volc_hal@76678

and get a positive response. I can't say exactly when this will happen, but it's catching up as we speak.

Dave

comment:6 Changed 11 months ago by taubry

Hi Dave,

Thanks, fcm_make_um now succeeded so at least this problem is solved. Is it clear why we could not use this revision? May this happen again with future revisions of the branch?

Thanks a million,

Thomas

comment:7 Changed 11 months ago by dcase

There was nothing special about that revision. There is a script on pumatest which updates the mirror, but if it fails then the data falls behind the main repository.

If the script fails again in the future then recent revisions will be at risk, but hopefully it works in a robust manner henceforth.

comment:8 Changed 11 months ago by taubry

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.