#3061 closed help (fixed)

Problem of submitting a UM suite

Reported by: jfgu Owned by: um_support
Component: UM Model Keywords:
Cc: Platform:
UM Version:

Description

Dear CMS helpdesk,

I have a problem in submitting my old suite u-ap259. It can be successfully run before. There is no error information. I am not sure what happened. I didn't change any set up in the suite. Please can you help with this problem? Thank you very much.

Best regards,
Jian-Feng

Change History (11)

comment:1 Changed 11 months ago by dcase

I think that your account of n02-REVCON is inappropriate. Are you still a member of this group? Can you submit a dummy calculation with this?

comment:2 Changed 11 months ago by jfgu

Hi, I just talked to Chimene Daleu. She is also using n02-REVCON and can submit her job and run the simulation successfully.

comment:3 Changed 11 months ago by dcase

I've done a dummy job with your settings, but replaced the group with something that I'm a member of. As it worked, I still suggest that this group choice is the first thing to look at. Perhaps you can ask someone with administrative rights to the group to see if anything has changed (I can't see any details of this)? Also you could try to do the build with another group, or do a dummy test submission with this and another group to confirm for yourself.

comment:4 Changed 11 months ago by dcase

I can see more information now. I've also looked at your ~/.profile and there are loads of things that are loaded which don't need to be there, hence there could be a conflict. Could you try commenting all of the module loads out of this and trying again?

comment:5 Changed 11 months ago by jfgu

Hi, do you mean the .profile under my account on ARCHER? The modules I load are ncview, python and cray-netcdf. I am not sure which of them are in conflict and has impact on job submitting. The modules loaded in my .profile are as following:

# Module Load
#module load cray-netcdf
#module load cdt/15.11
module load ncview
#module load anaconda/python3
#module load anaconda/python2
module load anaconda/2.2.0-python2
module load anaconda/2.2.0-python2 cf
#module load anaconda/2.2.0-python3
#module load anaconda/python3
module load cray-netcdf
#module swap PrgEnv?-cray PrgEnv?-intel

comment:6 Changed 11 months ago by dcase

You have a python conflict, so get rid of things relating to python. You should make your profile really clean and only load modules for the apps when you need them.

Comment out all the module loads, and the 'export PYTHONPATH=/…..' and try again.

comment:7 Changed 11 months ago by jfgu

It still doesn't work. I only load the python2 module. And I can confirm that I am a member of n02-REVCON by typing 'budgets' in ARCHER command lines.

The following are all in my .profile:

#export DATADIR=/work/n02/n02/jfgu

# Setup environment for running the UM under Rose
. /work/y07/y07/umshared/bin/rose-um-env

#export PYTHONPATH=/home/n02/n02/jfgu/package/skewT

# Module Load
#module load cray-netcdf
#module load cdt/15.11
#module load ncview
#module load anaconda/python3
#module load anaconda/python2
module load anaconda/2.2.0-python2
#module load anaconda/2.2.0-python2 cf
#module load anaconda/2.2.0-python3
#module load anaconda/python3
#module load cray-netcdf
#module swap PrgEnv?-cray PrgEnv?-intel

comment:8 Changed 11 months ago by grenville

Jiang-Feng

Check your .bashrc file on ARCHER too.

comment:9 Changed 11 months ago by dcase

Jian-Feng,

I originally asked about n02-REVCON, because there was no output to your submission scripts at the time, so I thought that they hadn't been accepted by the queue scheduler. As the output files appeared, the python clash became visible.

Am I correct in thinking that this works now? If so, feel free to close this ticket, and if not, feel free to ask another question.

Dave

comment:10 Changed 11 months ago by jfgu

Hi Dave,

You are right. This is due to the python clash. I had a setup in .bashrc file which setup a miniconda in my environment. Now the suite is able to be submitted and runs successfully. Thanks a lot for your help! We can close the ticket now.

Best,
Jian-Feng

comment:11 Changed 11 months ago by dcase

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.